cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble copying movies from camera to computer via USB [Vixia G50]

ljcollas
New Contributor

Camera: Vixia G50 camcorder

Computer: Windows10 desktop PC

While I know that I can remove the SD card from the camera and use a card reader to copy images to the PC, I have been trying to do that from the camera directly.  Each time I do so, I encounter a problem. 

My Windows 10 PC has no problem detecting the camera (camera set to "Media" mode), and Windows File Explorer allows me to drill down into the DCIM folder containing 5 4K videos, each ranging from 200KB to 5GB in size.  The problem occurs when I try to copy the videos to my PC.  The process immediately fails with an "Unspecified error".  I've tried the following variations:

-Different USB ports

-Camera on DC power 

-Camera on battery

I can easily transfer files to my PC from other cameras and recording devices, so I don't think it's my PC or computer skills.

Does anyone have any ideas?  I just bought the camera and I'd hate to have to send it back.

7 REPLIES 7

Nick2020
Product Expert
Product Expert

HI ljcollas,

 

Thanks for checking in!

 

To help us get a better sense of what you're facing, please answer the questions below:

 

Are you able to playback the footage on camera? That will let us know if you are running into corrupted data on the card itself.

 

Also, are you able to download even one clip at a time?

 

How much free space do you have on your computer?

ljcollas
New Contributor
I can playback the footage on the camera without a problem.
Not even a single file will transfer without immediately returning “Undefined error.”
Files transfer to my computer just fine via a card reader. I have over 150GB of free space on the destination drive.

mah1124
Occasional Contributor

I am having a similar problem with HFR700.  I have been able to upload for the past three years, but now I cannot upload videos recorded after April 2018.  This includes videos that I have previously uploaded.  The folders are present (visible in explorer), but it says they are empty.  I can view the videos on the camera.  I have not changed anything formatting wise, and the card has not been removed from the camera.  The Canon software shows the images with question marks, and says "Failed to import images" when I select Import.  When I select an older recording (April 2018 or before), it will import.

shadowsports
Esteemed Contributor

mah124,

Your issue is actually different.  Not only is your camera a different model, but your issue "?" on the files instead of seeing a thumbnail indicates a different problem.  The question mark, means the camera cannot read the file.  This can be a problem with the card itself, its formatting or corrupt files.

 

The G50 has a recovery process which can sometimes help with this.  I don't know if the HRF700 has a similar feature,.  However, splintering another users thread makes it difficult for us to assist and provide help.  It also makes it more difficult for people who are searching for answers. 

 

It might be best for you to start your own thread, as your issue deserves its own visibility. 

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw

shadowsports
Esteemed Contributor

@ljcollas,

Greetings,  I grabbed the G50 manual late last night to research this.  It states you should put the SD card  in a reader to transfer clips and files to a computer.  From experience however, I have dragged, copy or pasted files from other devices using "media" or "playback" modes in windows which basically detects them as a mass storage device.  So I realize this is the behavior you were expecting.

 

All of the things Nick2020 asked were questions which came to mind.  Ruling out file corruption, an issue with formatting, test moving one file at a time, and the amount of free space on the destination.  Permissions was the next thing I thought of but that was a longshot.

 

Is your card full size SD or is it a micro SD with an adapter?  We see a lot of issues in the camera forums with users who don't use full size SD cards. 

 

 

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw

Inapickle
Super Contributor

Checking the HF-G50 User Guide (on-line) I don't see any mention of transferring video files over USB. The transfer method described (on page 94, 'Working with Clips on a Computer') requires an SD card reader or computer with an SD card slot. So maybe direct USB transfer is just not possible, as it was on the previous HD camcorders ?

 

Edit: Checking the Pixela website also I see that application support for Canon camcorder models (i.e. Data Import Utility) ended December 2018.

 

http://www.pixela.co.jp/oem/canon/e/index_c.html

 

Accordingly, I don't think there is anything wrong with your HF-G50 or that the video files on the SD card have corrupted somehow.

SALLstice
New Contributor

I think I was having this same problem. I have a Vixia G50 and was using a USB to move files to my Windows 10 machine. The computer could see and files fine, but the file size on each was noted as being 3.99 GB, even on the files that I was certain were larger than that. When I attempted to move the files I got the "Unspecified Error" pop up.

 

I believe this is an issue with the different file systems. The memory card is formatted to ExFAT while my Windows 10 drive is formatted to NTFS.

 

However, I got a USB card reader and when I use that to move the files over, it works perfectly. The file sizes are noted correctly and the error does not pop up and the files transfer without issue.

 

For anyone else running into this issue I recommend buying a memory card reader. Otherwise, you should also be able to reformat the memory card (or your hard drive) so they use the same file system.