Canon Community Canon Community
 


New Contributor
Posts: 3
Registered: ‎01-04-2014
EOS 70D - computer doesn't recognize, and EOS Utiltiy doesn't work

Tomorrow is the deadline to return this POC. I've spent way too much time on this issue and it seems there are many many people who have also done so. First problem is Autoplay does not pop up which means the device is not recognized. Yes, I've tried all the ports. Yes, Autoplay is set to always ask with a device. I tried my Powershot and Autoplay works and it opens EOS Utility. But EOS utility is greyed out. I've called Canon support went thru everything, even installed the patch for the Utility.  No luck. Uninstalled just the Utilty and re-installed - Nada. Saw a message on some forum about hidden cannon config files..will look later as my pc is now being used for homework. But thought i'd give one last gasp, to see if anyone has a silver bullet.

Have seen lots of posts about buying a card reader - Will Canon supply a card reader? Doubtful..not one more red cent from me...

 

btw Window 7 sp1, EOS solution disk 28.2 + patch.

Who Me Too'd this topic
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement