Showing results for 
Show  only  | Search instead for 
Did you mean: 

Who Me Too'd this topic

EOS Rebel SL2 Camera Connect App not working with bluetooth


the first time I tried to connect my camera (Rebel SL2) with bluetooth to the camera connect app via bluetooth to my phone (android) worked perfectly, so it is so absolutely frustrating that after turning the camera off a few times, the connection seemed to not work anymore and when trying to set it up again, it wont connect at all.

The camera shows up in my bluetooth settings on my phone but I physically cant press the connect button to activate the connection, I click it, and it does absolutely nothing.

when trying to pair from the app, the error message that appears says "pairing failed: delete the camera from the bluetooth settings screen on your smartphone, and then perform the pairing again." I have tried this about 7 times now, including deleting the app, uninstalling the app, resetting all of the settings on both my phone and the camera and still nothing works.

I am beyond frustrated that this isnt working when I need it to, especially after already having it work once.

Who Me Too'd this topic