Showing results for 
Show  only  | Search instead for 
Did you mean: 

Who Me Too'd this topic

TR8520 won't scan after upgrade MacOS to 11.1 (Big Sur)


Had problems with printing and scanning, but solved (I hope) the printer problem.

When attempt to access scan function from System Preferences -> Printers & Scanners->Scan->Open Scanner get message "Failed to open a connection to the device (-21345)"  If connect printer to Mac then click on Open Scanner scanner will run single scan.

Worked fine under Mojave.  Not sure under Catalina, May have worked under original Big Sur and maybe 11.0.1 but definitely does not work under 11.1.  I added IJ Network Device Setup Utility and it says Printer is OK and test print works.  I attempted to install latest Firmware as of Nov. 2020, but it says already have Firmware v. 1.100 installed.When I looked for more recent drivers and other software first got message none for "Catalina (detected)" so Canon doesn't even know I'm running Big Sur.


What do I need to do to get my scanning function back?  

Who Me Too'd this topic