Showing results for 
Show  only  | Search instead for 
Did you mean: 

Who Me Too'd this topic

EOS R5 Connectivity Issue


Hi guys,


My EOS R5 cannot connect to any device (Macbook, iPhone, iPad) to transfer images.

When it is connected to Macbook the EOS Utility 3 does not recognize it. Even sometimes EOS Utility 3 recognized it the error occurs during starting transferring images.

When it is connected to the iPhone or iPad through Canon's Camera Connect app a similar error would occur during starting transfer images from R5 to the mobile device and the connection would be lost.


All the applications from Mac or iOS devices are updated to the latest version. My R5 worked yesterday. I have no clue what has been changed.

Now I cannot transfer any image from R5 to other devices using any application made by Canon. All the methods told by Canon's website have been applied in attempts of solving the issue. I can connect the R5 to my iPad Pro and import the images in the Photo app, which works perfectly.


Is there anyone having a similar issue?


Updates on 09-26 2020:


After quite a while since the post was created on 08-13 the issue persists. Bluetooth connectivity never worked. WIFI connectivity can be successful but unstable. The "target not found" error frequently happens in R5 when EOS utility is being used to transfer images and videos via WIFI connectivity between R5 and Macbook pro (Catalina 10.15.6). After not using the wireless connectivity feature for weeks it might work once with no issue when I tried. Once it worked with no issue for once it becomes unstable and unusable with errors.

The worst part of this issue is that Canon may not be able to reproduce the same issue on their end. Moreover, it is not persistent. I can only hope that Canon will eventually find out the defect they introduce in the software or hardware and fix it in the later framework update.


Upddates on 04-05 2021:


My issue was mainly the unusable conectivity with any type of connection between the EOS R5 and the computer/iPhone/iPad including USB-C cable, wifi and bluetooth.

The issue was significant while the USB-C cable was not working. I couldn't use any feature from the EOS utility like taking live shots from control of the computer or importing any photos/videos from the camera to computer/mobile devices. I had to use card readers to import my work every time. Later, I found that Imagin Capture or Google Photo app can actually detect the photos from the R5 via USB-C connection though Canon's EOS utility cannot detect the camera. The issue ws definitely only caused by the code in EOS Utility app of both Mac and iOS versions, not the USB-C connectivity.


The USB-C cable connectivity started working since the update of firmware 1.2.0. There was no clude how it was fixed for my camera as there is nothing mentioned in the update notes related to the connectivity issue. It magically started working with no issues in the use of all features of EOS utility.

Even nowadays I still haven't tried to use any wireless connectivity of R5. I don't have the confidence in the stability any more. Instead of wasting time to debug any protential issue I am just always using the USB-C cable for the connectivity.

Who Me Too'd this topic