Canon Community Canon Community
 


New Contributor
Posts: 2
Registered: ‎07-27-2018
EOS Utility will not launch, shows splash screen then exits; windows 10

I've been using EOS utility for months with my 70d and it's been fine. A few days ago it just stopped launching. The splash screen shows and then goes away and the main window never shows up. Happens with both EOS Utility and EOS Utility 2.

I tried a system restore to before the issue with no luck. I have no antivirus programs running besides windows defender. I uninstalled all recent software installations with no luck. I deleted and reinstalled the software, ran the updater, no luck. Finally I did a windows reset/reinstall, and it worked... Until the next restart, and now it's broken again.

 

Please help I need this software for my work.

Who Me Too'd this topic
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement