Canon Community Canon Community
 


Occasional Contributor
Posts: 6
Registered: ‎12-15-2017
Re: Canon Pixma MX922 not printing red

Okay here Goes! Just bought this 922 from Amazon for $69 bucks, to replace an old MX 870. I'm running a mac with the latest upgrades. My PGBK was doing the same thing. Test page no joy. I fussed with all the menu settings on the printer, nada.

I downloaded all the printer and scanner drivers from Canon, nada. I gave the iMac and printer a hard reboot, unplugged everything, restarted, nada. Checked all proxy, wireless settings, etc, nada. Yanked the cartridge, shook it, reinstall, nada.

The cartridge is brand new! Test page all colors minus PGBK. Checked forums, google,nada. Deleted all printer and scanner drivers, fearing corruption, reloaded all new latest again from Canon, nada. 20 test pages later still nothing, Getting close to tossing out to trash tonight. Took PGBK cartridge out again, noticed a 1/4 inch of orange tape on the front of the cartridge, no way, I'm saying. peeled it off, got a little rubbing alcohol applied to a Q-Tip ran it around the front and back of cartridge, especially into the ink hole, looked dry, probably voided my warranty. Then I ran the same alcohol infused Q-Tip where the cartridge gets seated, heck at this point I was ready to burn sage, wave it around the printer and chant. Went to test page and OMG it worked!!! Could a small bit of tape on the FRONT of the darn cartridge cause this? Or was the alcohol a priming agent? Beats me, All I know is that I have been fooling around with this nonsense for two days and nothing else worked!

So give it a shot and let me know!

View solution in original post

Who Me Too'd this solution
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement