Showing results for 
Show  only  | Search instead for 
Did you mean: 

Who Me Too'd this solution

Thanks, Stephen.


Your link went to the G7X. I do have a G7X Mark II (apologies for the confusion). That video is here. I'd watched that video several times and my experience matched it until 4:58, at which point my PC did not make the "connection noise," didn't ask what I wanted to do when the device connected, and the camera continued to display "Connecting" as shown at 4:32 (until it timed out).


HOWEVER, on a whim I ran the Windows 10 Troubleshoot program and chose Hardware and Devices. It reported a problem with the Canon driver, did some magic, prompted me to reboot, and voila! The next time I went through the steps it worked!


Thanks for your, and others, assistance! Although those suggestions weren't the solution, they kept me hunting until I (er, the Troubleshoot program) discovered the faulty driver. And FWIW, I had removed the device from the Devices and Printers dialog a dozen times (although it was still displayed in that dialog after removing it--a sign of trouble I expect) and checked to make sure it wasn't in the Device Manager (it wasn't). In any case, I'm up an running.


Happy Camper

View solution in original post

Who Me Too'd this solution