Who Me Too'd this topic

Canon: Best Cameras, but Worst Customer CARE?

KenE
Apprentice

As a long-time lover of Canon's Powershot cameras, I've grown accustomed, and been quite willing to put up with, its user-unfriendly site, clunky software and various glitches and snags that come with getting set up.

 

With the new SX700, another amazing camera in the series, Canon Image Gateway ("CIG") sounded ready enough to take the time to set it up, along with the wireless CameraWindow app on mobile devices. I'd like to emphasize how many years of great photos Canon has given our family on vacations and special occasions, because the rest of this is not especially pretty.

 

Matters DID start well with the CameraWindow app. Installing it onto my S3 and Kindle Fire (side-loaded its apk) went smoothly. I can transfer images from camera to phone and tablet! Nice start, since it's a just a short hop from there to social-posting.

 

--

 

[[ By the way, for those who use Kindle, I highly recommend the APK Downloader extension for Chrome (for when an app is not available for Kindle directly). I found it while searching for the APK for this Canon app.

 

You enter the URL of the app (i.e., URL from Google Play). The app downloads the "official apk" to your desktop!

Transfer the apk onto your Kindle and then install it using a file manager.

 

You can count on the apk being virus-free since it comes from Google Play. Many apk sites don't have the more specialized-type of apps and there's always the worry about how clean their apks are. ]]

 

--

 

But I digress...

 

Back to Canon's Image Gateway. I should have stopped with CameraWindow on mobile devices, but was tempted by the ability to upload directly to social media from the camera via Canon's site (although it's not clear if it can do that in one-step).

 

What a pain. Canon's site asks me (you, too?) to log in to CIG even though I've already logged in. I can access my account, see that my 700 is registered, etc., but I'm asked to login again.

 

This would normally be just another one of Canon's inevitable glitches/low-usability issues (ex., one of its certificates is questioned by both Safari and Chrome with worrisome "careful" language, some parts are ambiguous and need figuring out, etc).

 

But the really big issue is that when I DO try to login (when already logged in), I get this error page, no matter which browser I try...

 

https://www.cig.usa.canon.com/error/general.html

 

I've tried many workarounds, looking for backdoors that take advantage of the fact that I'm already logged in, even downloaded their Gateway Album app to see if that might find a backdoor to login to Canon Image Gateway (desperate, I know). Same result - the app won't even login.

 

--

 

I finally(!) got the idea to see if was "just me" who couldn't figure this out. I did a search at Google for "cannot login to canon image gateway"...

 

https://www.google.com/#q=cannot+login+to+canon+image+gateway

 

This is, it seems, a BIG problem, especially when you consider that most folks just give up rather than come to forums, making what we see (here and in the Google search) just the tip of the iceberg. And it's been happening for many months.

 

Canon gives a variety of excuses, ranging from "server down for weekend maintenance" to the user being in a foreign country (don't lots of people use their cameras when traveling? -- global access would surely be a big part of this?).

 

Canon's basic strategy seems to be to bury the problem by telling folks to contact Support (whether it's at YouTube, their social media locations or here). Canon looks good by replying (and they do it religiously). If the intent was genuine, it would be admirable. But folks seem to enter a black hole and never come out.

 

Where are the happy "thanks for fixing that for me" customers? Almost everyone complains that they wasted hours with Support, repeating the same troubleshooting that they'd already spent so much time on. Some report being told that they were the only ones with the problem, clearly not true.

 

So I have no interest in wasting yet more of my time on this by contacting Support. (I did find one person who later managed to login, but that did not seem to be connected to his contacting Support, given the delay and lack of on-point communication from Canon.)

 

--

 

This is a disrespectful-to-loyal-customers attitude, no way to handle what should be a very simple problem. It boils down to this...

 

1) Logging into websites has been mastered by webmasters/sysadmins long ago.

 

2) The Image Gateway is now an essential, core functionality, especially if this actually enables users to upload directly to Facebook from the camera (once all is set up).

 

3) Even if it worked, there must be a faster way to set this up, to build the software into the camera? Canon could really use a Web-based UI-centric team that eliminates all the needless little barriers along the way. A customer CARE attitude starts well before having to post to a forum or contacting Support.

 

4) I love the Powershot cameras. The SX700 makes up for the disappointing 280 (with its video-related battery problem and minor changes). For example, the image stabilization on the 30x zoom of the 700 is amazing (the 30x itself is fantastic). And low-light shots are better than ever. The hardware is why so many of us stick with Canon.

 

The software has always lagged, something Canon can't afford in the long run, not anymore. Before worrying about that, though, customer CARE starts with paying attention to all the complaints and prioritizing THIS particular issue so that everyone can login painlessly.

 

In SOFTWARE companies, bugs that are "total stoppers," frequent and simple-to-fix - they normally get prioritized to the top. It's hard to understand why this is still an issue.

 

It's time to stop sending us to Support and instead to just fix this problem. We should be able to...

 

Enter username and password. Get in. Set up what is now core functionality painlessly. Get out. Watch happily as it all works perfectly after that.

 

With respect but frustration,
Ken

 

P.S. A quick follow-up. Installing that Gateway Album app actually DID seem to help. Some 2 hours after the initial failure, I can now login using both Safari and Chrome! The timing is too tight to be coincidence, although I've no idea why it works now.. However <sigh>...

 

The camera can no longer find the mobile devices (a big step back) and it won't give me an authentication code. And so it goes... the temptation to lose yet more time. Must resist and move on.

Who Me Too'd this topic