Canon Community Canon Community

Occasional Contributor
Posts: 5
Registered: ‎12-04-2017

WiFi problems, PRO-100 and macOS Sierra

Using macOS Sierra. Attempting to communicate with PRO 100 by Wifi.


My issue: Printer always shows as "Offline" in the system preferences.


I have tired numerous things. Went through setup from the supplied CD-ROM a couple of times. Seemed to succeed. For instance the setup software said that it was able to find the router and seemed to imply it could locate the printer, even after the USB cord was disconnected.


However, printer still shows as "Offline." Tried rebooting both printer and Mac. 


Also tried to use WPS connection. Seemed to succeed. The blinking WiFi light on the printer immediately changed blink patterns and then stopped blinking when I pressed the button on the router. 


However, printer still shows as offline. 


There is no firewall. No networking problems in my home; all other printers and computers are available over the network.




Product Expert
Posts: 350
Registered: ‎01-20-2016

Re: WiFi problems, PRO-100 and macOS Sierra

Hi canon1127,


Let's start by checking the printer's connection to the network.


You can print out the network settings of the printer such as its IP address and SSID.


  • This print out contains valuable information about your computer. Handle it with care.

    1. Make sure that the printer is turned on.

    2. Load a sheet of A4 or Letter-sized plain paper.

    3. Press and hold the RESUME/CANCEL button until the POWER lamp flashes 6 times.

    4. Release the RESUME/CANCEL button.

      The printer starts printing the network setting information.

Much of the information will not be relevant, but the important things to look at are:

  1. Is the connection active or inactive?

  2. Does the SSID (network name) match the one the computer uses?

  3. What is the signal strength?

  4. What is the IPv4 IP address?

Occasional Contributor
Posts: 5
Registered: ‎12-04-2017

Re: WiFi problems, PRO-100 and macOS Sierra

Thanks for reply. Actually I solved it. Here's what happened:


- note that newer routers don't have that WPA button, so that method is out


- I added the printer via USB to set up the network settings


- I then disconnected the printer from USB and noticed it was showing as "disconnected"


- I thought that meant the wifi wasn't working


- I discovered that I needed to add the printer all over again as a networked printer ... it turns out that the macOS sees a printer connected via USB and one connected vis WIFI as two different printers



Occasional Contributor
Posts: 8
Registered: ‎02-04-2018

Re: WiFi problems, PRO-100 and macOS Sierra

[ Edited ]

I have this printer and have both Sierra and High Sierra and have experienced the "printer offline" issue when the printer is conncted via WiFi and using Bonjour. I "solved" the issue by hard-wiring the printer to my Ethernet switch and using the Canon IJ Network protocol. For my small office environment that was an adequate solution but it was way more work than I had hoped for. I am having other issues with Canon printers (MF733C and 6230) connected via WiFi and using Bonjour. These printers will periodically go offline with both Macs. Again, a "fix" is to use a hard-coded IP address and the LPD protocol, but that's less than ideal because it means I need to configure my router to always handout the same IP address to the printers (or to not assign IP adresse in the range I configure the printers to use a static IP in).


I am still investigation this sisue to see if it's an issue with Canon's Bonjour implementaiton, an issue with OS X or an issue with my WiFi system. There is an active disucssion going on in the Apple community forum that you may want to follow as well.

New Contributor
Posts: 1
Registered: ‎06-03-2018

Re: WiFi problems, PRO-100 and macOS Sierra

I am having a similar issue with connecting my Pro-100 on a macbook pro running highsierra.  My wireless lan is enabled but the connection is inactive.  The SSID name matches that which the computer is connected,  signal strength is 0% and there is no IPv4 or IPv6 address specified.  No matter what I do, i cannot get the MBP to find the printer.  It was working fine before the upgrade of the OS.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement