Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎08-06-2015

Unable to get Google Cloud print to work on my MG6220


I can print and scan normally on my MG6220 connected to my wired home network. My computer OS is Windows 8.1. Printer firmware has been updated to V 3.020. The printer will show up when I go to Google Cloud Print but is always grayed out and shows off line.

I noticed that the grayed printer name on GCP web site is: Canon MG6200 series_7CE5F5 while the working printer name on my network is CNBJNP_6A31AF. Canon IJ Network tool shows those 2 ports, the _7CE5F5 one has no driver and not detected, I guess that’s the wi-fi lan port? I've registered, de-registered, and re-registered several times. I can’t find a way to correct those behaviors. I've looked all over and can't seem to get a straight answer on this.

Can you help?

Occasional Contributor
Posts: 11
Registered: ‎06-25-2015

Re: Unable to get Google Cloud print to work on my MG6220

I sent an email to canon at <>;.


I received the following response within 4 hours.  I tried this work-around method of Cloud Printing, and it worked.  It is more steps than the original Cloud Print capablility the printer once had, but it works and doesn'tt require a Windows computer to be connected to the printer for 'classic print'


Even thought the printer shows 'offline', I was able to 'pull' the job from the queue using the method below I received in the email from Canon technical support:




Thank you for contacting Canon product support regarding the Google Cloud Print issues with the PIXMA MG6220.

I understand you are unable to print from your Chromebook and Android device via Google Cloud Print. I understand this is frustrating to have it work one way previously, and then change so that it does not. Google Cloud Print is a Beta service, and as such, is constantly having changes made to the service that have affected usage and reliability. Recently, they applied a significant security protocol update that essentially changed how their servers authenticated registered units. In order to make our printers fully compatible again, a firmware update would be required. You noted that this particular unit, along with several others, are not going to receive a firmware update. This is due to the age and technical limitations of the models; they are physically unable to be updated to the new standard.

Now, that is not to say that you are without options. Is the printer still registered, but listed as offline? If so, you can select the offline unit and select print, putting a job in the queue. Once the job is queued, you can then manually pull queued jobs from the Google Cloud Print server using the 'Start Cloud Print" selection from the operation panel. The instructions on how to do so are listed below.

1. Confirm that the printer is turned on.



2. In the [HOME] screen, select [Special Print].



3. Select [Start Cloud Print], and touch the OK button.



4. The message is displayed asking if you would like to connect to the server to check for the print data.
Select [Yes] using the up or down cursor button, and touch the OK button.



5. When print data exists, it will be received and printed by the printer.


Next, you mentioned that you were using Google Cloud Print to print from your Android device. Do you know what version of Android you have? Depending on the version, you may be able to use the Canon Print Service or the Canon Print Inkjet/Selphy app to print from your phone instead. You should be able to check the Android version from your Settings app, under a section that will say something along the lines of  'About this Device.' If you reply with the version of Android your phone is running I'd be happy to give you instructions on how to utilize the wireless printing functionality without using Google Cloud Print.

I hope this information is helpful to you.  Please let us know if we can be of any further assistance.

Thank you for choosing Canon.


Technical Support Representative

New Contributor
Posts: 2
Registered: ‎08-06-2015

Re: Unable to get Google Cloud print to work on my MG6220

Thanks for this work around using Google cloud print.

I'm interested in knowing more about the use of the Canon Print Service. My Android device is a Samsung S6. OS version is 5.0.2.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement