Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎01-27-2021

Unable to connect IP8760 printer to network, Canon support won't help

Just a heads up if you are looking to buy the IP8760 to use on your network. 

 

I was hoping to be able to print to the IP8760 from various laptops, ipads etc in the home. We have a small Selphy printer which connects to WIFI no problem.

 

The first thing to note is that there is no ethernet port on the 8760, so no option to connect it to the router that way. This is how my previous Epson printer was connected.

 

I tried all methods of connection including WPS, temporary use of a USB cable, cableless installation. In each instance I would end up with error messages that the printer could not be detected on the network. Also a heads up, if a password for this printer is requested it is the serial number which can be found on the back of the printer, or on the box. The need for a password was not mentioned anywhere in the documentation and I had to find out via the forums here. 

 

The closest I came to connecting the printer to the network was via a USB cable. It detected the printer, allowed me to enter the WIFI credentials and printer password but then came up with an error message and suggested auto IP address detection. This did not work.

 

I called Canon support and the support person knew less than I did from searching the forums. He got me to do the usual reboot of modem and printer. I explained all the steps I had taken in the 3 hours I spent on it last night but he wasn't listening.

 

When he got to the same point I did he had no idea what to do. I suggested maybe it was router settings and he replied "Yes it must be and that is beyond our scope". I understand that Canon can't be expected to diagnosed every make and model of router but SURELY they could at least let me know what settings are required?

 

The router is set to 2.4Ghz only.

 

So now I've had to install my printer via hard cable and I am unable to access it on the network. I am looking at returning it. 

 

If anyone has any suggestions of what I could try I'd be very grateful.

New Contributor
Posts: 1
Registered: ‎02-16-2021

Re: Unable to connect IP8760 printer to network, Canon support won't help

Hi
I have just got off the phone from Canon after 2 hours and they have told me to go & buy a USB cable and try to connect that way. I asked why they don't supply it with purchase??
I had issues connecting this printer previously and had to load a new driver, which took forever as it still wouldn't connect.
I just received a new modem and have contacted Canon again and they have told me they can't help me after trying different options.
So now I have a printer that does not serve the purpose it was bought for i.e. a wireless printer.
Very frustrating
New Contributor
Posts: 2
Registered: ‎01-27-2021

Re: Unable to connect IP8760 printer to network, Canon support won't help

It sounds like you had the same experience as me. It is incredibly frustrating. I already had a USB cable and tried to set up the wireless connection with it, but it failed. I know have my computer connected via the USB directly and I am unable to use the wireless functionality (eg printing from laptops and ipads) which is one of the reasons I bought it!

 

I was also told they won't help me any further. My only option seems to be to pay an IT person.

 

I'm sorry you have had the same experience. It seems as though there are many of us, but Canon isn't too interested in resolving the issue. 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement