Canon Community Canon Community
 


Reply
mc2
New Contributor
Posts: 1
Registered: ‎03-22-2019

TS6100 Driver over WiFi not printing

Hi,

 

I have a TS6151, a Windows 10 Pro Desktop and a W10Home Laptop, both x64, both v1809, and printing over WiFi from both the desktop and laptop has stopped working.  It used to work fine but as I only use the printer very rarely I'm not sure when it stopped working, just that it last worked at the beginning of February and I don't think anything has changed on either system since, other than Windows updates.

 

Now, I say printing over WiFi no longer works but actually it's printing over WiFi with the  Canon TS6100 series driver that no longer works -- printing over WiFi using the Microsoft IPP Class Driver works fine!

 

In fact, everything else works fine when using the Canon TS6100 series driver, including:

  • printing over USB
  • scanning over both WiFi and USB
  • getting the status over WiFi with the IJ Status Monitor (it says Printer is online and shows me the ink levels)
  • being able to do Maintenance functions over WiFi with the IJ Printer Assistant Tool (I can change settings, invoke cleaning, power off the printer, etc, etc)

So, it isn't a connection problem, the WiFi itself is working fine.  It's just printing over WiFi with the Canon TS6100 series driver that's the problem.

 

In experimenting I've got the printer installed several times, some by reinstalling the whole package (both from CD and downloaded MP drivers) and some by "Add a printer or scanner" in the Windows Printers & scanners setup, with the following results when trying to print something:

 

1) Port: WSD-1a3079..., Description: WSD Port, Driver: Canon TS6100 series

Nothing happens, Status in Print Queue is a fast Error-Printing-Restarting loop

 

2) Port: IP_192.168.1.10, Description: Standard TCP/IP Port, Driver: Canon TS6100 series

Nothing happens, Status in Print Queue is Printing but just hangs on that forever

 

3) Port: WSD-e4f2a2..., Description: IPP Port, Driver: Microsoft IPP Class Driver

Works!  Prints fine (but of course I don't have all of the Canon driver settings or the IJ Status Monitor)

 

In the first two cases the printer itself does absolutely nothing, including nothing showing on its LCD panel.  Note that changing the driver in 1&2 to the Microsoft IPP Class Driver doesn't help, and changing the driver in 3 to the Canon one results in the IJ Status Monitor saying "Printer not responding."

 

Things I've tried include resetting the printer, updating the firmware (it was up to date anyway), removing the Canon TS6100 series MP Drivers and reinstalling, both from the CD and downloaded from the Canon site, and removing and re-adding the printer in Windows, multiple times.

 

Any suggestions welcome! :-)

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement