Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎04-20-2017

Re: Pixma MG5420 WiFi connection problem


@Another_Victim wrote:

This is a reply to JJo's 9-13-2013 post in which JJo suggested disabling the printer's Wireless LAN DRX setting.

 

My Canon MG6320 has the same problem as the OP of this thread: After hours of printer inactivity, the printer won't print. (Nor will it scan from the pc's Canon utility software.)

 

Disabling the printer's Wireless LAN DRX setting did not solve the problem.

The only "solution" that works for me has been to turn the printer off and on. The print job that was stuck in the print queue automatically resumes and prints okay. (Turning it off & on also re-enables the ability to scan.)

But this workaround appears to waste ink (and it's a little inconvenient).  So I hope someone will suggest a genuine fix.  My bet is that Canon will need to provide a firmware update for the printers.

While the printer is in its buggy disconnected state, its menu shows it still thinks it's connected, and it still shows the correct IP address.

Another troubleshooting step I may try is to re-enable the wifi router's SSID radio beacon. The router broadcasts the beacon by default, but I keep the beacon off for extra security. (I disabled the beacon after the printer's initial connection succeeded.  The printer seems to remember the router details okay.)  Because turning the printer off & on causes the printer to reconnect, it demonstrates that the beacon shouldn't be needed, but if the printer firmware is buggy I suppose anything is possible.


Okay I think i've got this type http://192.168.1.254 into browser I took my WIFI channel off auto and put it on 7. I also changed the frequency to 40MHz. I don't know much about this stuff but it seems to be staying connected and i'm able to print from my Iphone, Ipad and laptop. I also connected using my WPS pin. I can't really remember how i did that, but I did it from the printer and it gave me a pin to put in when you go to  http://192.168.1.254. Anyways, it's working for me.....it might just be dumb luck but i hope this helps out.

New Contributor
Posts: 2
Registered: ‎04-20-2017

Re: Pixma MG5420 WiFi connection problem

[ Edited ]

Okay I think i've got this type http://192.168.1.254 into browser I took my WIFI channel off auto and put it on 7. I also changed the frequency to 40MHz. I don't know much about this stuff but it seems to be staying connected and i'm able to print from my Iphone, Ipad and laptop. I also connected using my WPS pin. I can't really remember how i did that, but I did it from the printer and it gave me a pin to put in when you go to  http://192.168.1.254. Anyways, it's working for me.....it might just be dumb luck but i hope this helps out.

 

Okay I've noticed when I change it to 20MHz My Canon MX490 disconnects. When I change it back to 40MHz it reconnects and thus I can print. Really hope this helps.

So http://192.168.1.254 into browser change channel frequnecy from 20MHz to 40MHz And take WiFi channel off "auto"

New Contributor
Posts: 1
Registered: ‎05-01-2017

Re: Pixma MG5420 WiFi connection problem

Every time my cable company makes changes to their Menu, my printer loses the wifi connection to all of my Apple products.
You can call Cannon Corporation and get someone to walk you through resetting the
WiFi connection.
New Contributor
Posts: 1
Registered: ‎01-18-2018

Re: Pixma MG5420 WiFi connection problem

Thanks, this method worked. My canon MG5422 was able to connected to access point. I could not see it on router (NETGEAR R7000) network mapping, nor printing or scan. The above method fixed the problem!
Highlighted
New Contributor
Posts: 1
Registered: ‎10-07-2018

Re: Pixma MG5420 WiFi connection problem

This is for you and every one else that is losing there printer connection after a period of time.  What you need to do is set a static ip in your router for your printer.  Login to your router and dothe following:

1) Select advanced settings

2) IP address distribution

3) Connection list

4) Find your printer and edit

5) Check the box for Static Lease Type

6) Save the setting

 

These are the instructions for a FIOS router but other routers are simular.  This will fix your problem.  You need to do the same thing if you have a wifi thermostat.  Set a static for your device is the key.

New Contributor
Posts: 1
Registered: ‎01-29-2019

Re: Pixma MG5420 WiFi connection problem

I had exactly the same problem with a 8200 series printer. After some trying I found out that the issue is not in the printer but in the router. If the printer uses DHCP, it obtains an IP address from the router. However, this IP address is not valid forever: after some time the lease of this IP address is over, and the connection wil be lost. It is only possible to reconnect by requesting a new IP address (done by manually reconnecting to the router).

I solved the issue by entering a fixed IP address in the printer, in the LAN settings menu, select Wifi, then settings again, then advanced, Tcp settings, ipv4, IP address.

this wotks fine for me as there is no lease time on fixed IP addresses.

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement