Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎08-31-2015
Accepted Solution

My MG 5220 no longer works on a wireless network from my desktop PC.

I have tried uninstalling and reinstalling all software. The last uninstall, I also cleaned out the registry of all Canon related items. Nothing works. The symptoms are I can install and log on to the network and print. But if I shut off the PC, I'm back to zero, unable to print with the message "Printer Offline". The printer shows "Wireless LAN Active"

 

The printer is also installed wireless on the same LAN to a laptop. Printing/scanning/copying from the laptop is no problem.

 

After restarting the desktop, the Canon IJ Network tool shows the printer is "offline" with the same port as shown on the laptop IJ Netwrok tool below. "Devices and Printers" only shows MG 5200 Series Printer - Offline

 

The laptop "Devices and Printers" shows:

     Canon MG5200 series Printer

     Canon MG5200 series Printer WS

     Canon MG5200 series Printer XPS

 

The laptop Canon IJ Netwrk tool shows 2 printers:

     Canon MG5200 series Printer - Offline - Canon MG5200 - CNBJNP_8887171518AE

     Canon MG5200 series Printer - Available - Canon MG5200 - CNBJNP_8887171518AE

 

I'm at my wits end. I don;t know what else can be done. Suggestions please!

Occasional Contributor
Posts: 16
Registered: ‎08-04-2014

Re: My MG 5220 no longer works on a wireless network from my desktop PC.

Hello JohninNJ,

 

To have a better understanding of your issue, please let everyone know what operating system (Windows Vista/7/8 or Mac OS 10.X) you are using. That way, community will be able to assist you with suggestions appropriate for your product.

If this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team.

Thanks!

New Contributor
Posts: 3
Registered: ‎08-31-2015

Re: My MG 5220 no longer works on a wireless network from my desktop PC.

The laptop is running Windows 10 while the desktop is running Windows 7 SP1.

 

Wireless printing from both was fine until I had a big problem installing an update to a AMD video card driver on the desktop. It caused the USB ports to disappear. I got out a backup bootable hard drive and had no problem updating the video card. The backup HD however had the MG 5220 connected via USB. I deleted all Canon software via uninstall and started from scratch with the goal of reinstalling the printer as wireless. But the results have been far from what I expected.

 

There is a "Reset" command on the printer menu that I haven't tried yet. Later today I'm ging to give that a shot while deleting, again, all Canon software and registry items.

Product Expert
Posts: 3,253
Registered: ‎10-16-2012

Re: My MG 5220 no longer works on a wireless network from my desktop PC.

Hello.

 

Check to see if your computer is connected to the same Wi-Fi router as the printer.

 

If so, try uninstalling both the drivers and IJ Network Tool, then reinstall the MP Drivers from our website at the following link:

 

MG5200 series MP Driver

 

This didn't answer your question or issue? Find more help at Contact Us.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 3
Registered: ‎08-31-2015

Re: My MG 5220 no longer works on a wireless network from my desktop PC.

After 4 days of regular pc use, i.e. booting up and shutting down numerous times a day, and after each boot checking the printer via Canon IJ Network Tool, and not having made ANY changes to either the printer, pc or router (yes, I have only 1 router and yes, all drivers and software were downloaded from the Canon website to insure they were the latest available and yes, I downloaded over and over to insure there was nothing wrong with the transmission), the printer is now visible to the network and functioning as a wireless printer,

 

The IJ Network Tool still shows 2 MG 5220s. one available and one unavailable, while my laptop shows 4 MG 5220s, of which only 1 is available. Windows 7 Devices and Printers menu wshows only 1 MG 5220, but as Copy 2. The laptop running Windows 10 also shows only 1 MG 5220 in its settings menu.

 

At this point I don't care about the unavailable or Copy 2 printer designation. I'm tired!

New Contributor
Posts: 1
Registered: ‎03-21-2019

How do I change printer computer ports?

New modem lost my wireless printer connection.  I downloaded drives and now it shows: Canon MG5200 series Printer XPS

 

1) What is Printer XPS (I have MG5220 series)

2) Computer not recognizing port; how do I change ports?

 

Help, please....I'm tired!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement