Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎01-08-2021

Mf644cdw suddenly can't find, wired or wireless

[ Edited ]

New printer has worked great for a month. Today tried usual wireless print and couldn't find it. Did a bunch of searches on printer to verify correct network, reconnecting to the wifi, then gave up and connected via USB and it still can't find printer.  Powered off and on twice. What next?


Tried later deleting printer then reinstalling and it began to print immediately using the USB connection. However the wireless still does not work. 


Now two days later...if it's any help. I think we briefly lost power just before this problem began. What could that have done to me?


NEW COMMENT on January 23. It does still print but the pattern is exactly as described below by GDP....printer drops off and shows "not connected" etc etc until I delete and add it back in, after which it will print. Have not yet got to the final point of not printing at all but afraid it will happen. This has to be a Canon software issue. 


I'm considering returning it to get my money back, which is too bad because it does a great job when it works. 

New Contributor
Posts: 1
Registered: ‎01-23-2021

Re: Mf644cdw suddenly can't find, wired or wireless

This problem has been happening to me for months.  Every couple of weeks I have to remove and re-add the printer to my Mac.


But this morning it got even worse.  We can't print from any device, laptop or Airprint, on our network.


I have updated to the latest firmware on the printer.


I have removed the printer from my printer list on my Mac.


I have updated to the latest printer and scanner drivers from the Canon website.


I have re-added the printer to the printer list on my Mac.


I have rebooted my Mac.


I have rebotted the printer.


I have reconnected the printer to the WiFi network.


The IP address shown for the printer both on the printer and on the Mac is exactly the same.


The printer says it is connected to the WiFi network.


The Mac says the printer is on the network and green light idle.


The printer sends supply information to the Mac, which matches the information on the printer.


But when I try to print a simple Word document the Mac, the Mac says the document is ready to print on the server but the "printer is not connected."


Yo, Canon, throw us a bone here!

Posts: 2,031
Registered: ‎07-08-2013

Re: Mf644cdw suddenly can't find, wired or wireless


Thanks for posting on our forum! This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement