Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎10-30-2013

Re: MX892 Keeps losing connection when needed.

I have an MG6200 that got the same message "There are ports that cannot be used..." I switched to wired and reset printer to LAN, no luck.  I switched to wireless and set up that.  No luck.  I set back to wired, and went to DOS PROMPT and pinged the IP address from the wired lan.  Then the printer started printing happily away.  I think there's a problem with the proprietary IP communication that Canon is using.

Occasional Contributor
Posts: 5
Registered: ‎09-18-2014

Re: MX892 Keeps losing connection when needed.

I have the same problem ... MX892 ... Belkin router ... No problems with any of my other computing devices staying connected to wifi.

 

After the Canon goes to sleep, I can never print to it as the printer is never found.

 

I have to go to the printer every time and re-find the router.

 

Please help. Very frustrating and a productivity killer.

Frequent Contributor
Posts: 113
Registered: ‎08-28-2014

Re: MX892 Keeps losing connection when needed.

Hello josephvellino!


Welcome to the Canon Forums and thanks for your post!

To have a better understanding of your issue, please let everyone know what operating system (Windows Vista/7/8 or Mac OS 10.X) you are using. That way, the community will be able to assist you with suggestions appropriate for your product.

Any other details you'd like to give will only help the Community better understand your issue!

If this is a time-sensitive matter, our US-based technical support team is standing by, ready to help 24/7 via Email at http://bit.ly/EmailCanon or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 10 PM ET (7 AM to 7 PM PT).

Thanks!

Occasional Contributor
Posts: 5
Registered: ‎09-18-2014

Re: MX892 Keeps losing connection when needed.

OS X 10.9.5

Occasional Contributor
Posts: 5
Registered: ‎09-18-2014

Re: MX892 Keeps losing connection when needed.

Just to confirm, other machines on prem are Windows-based. We don't print from them, but I just did a test and they can't print to the Canon MX892 after it has gone to sleep, either.

 

The printer continuously needs a forced connection to wifi.

Highlighted
Occasional Contributor
Posts: 5
Registered: ‎09-18-2014

Re: MX892 Keeps losing connection when needed.

Interestingly (to me, at least), I just scanned a document and the computer found the scanner with no problem.

 

I then went to print and the computer couldn't find the printer. I connected the printer to wifi again via the menu setting on the printer and was able to print.

 

So the computer found the scanner without problem but could not then immediately print to the same device until I used the menu setting on the printer to connect to wifi.

Occasional Contributor
Posts: 21
Registered: ‎08-10-2014

Re: MX892 Keeps losing connection when needed.

On 2014-10-06 I posted the details of the solution that worked for me at a similar Canon forum:

 

http://forums.usa.canon.com/t5/Printer-Multifunction-Support/Mx920-Wireless-printing-problem/m-p/118...

 

It continues to work for me.  The wireless printer connection hasn't failed since then.

 

It's a permanent solution that you only need to do once. (It isn't a workaround that wakes the printer temporarily after its connection fails.)

 

The solution involves using your computer's web browser software to access the printer's built-in web server (by entering the printer's IPv4 address into the web browser's address field), going to the printer's Settings webpage, and entering a value in the Location property. (Which was blank by default.)

 

If you try it, please post (preferably in that other Canon forum) a few days afterward, to report whether it solved the problem.

 

Good luck!

New Contributor
Posts: 1
Registered: ‎01-14-2015

Re: MX892 Keeps losing connection when needed.

Worked for me today 2014-01-13. Thanks so much for sharing!
New Contributor
Posts: 1
Registered: ‎07-27-2015

Re: MX892 Keeps losing connection when needed.

My MX892 worked fine for a few months, but it now seems to "forget" its connection to our local network after every use.  This means that we have to manually key in the password to the network every time we print for it to work.  Otherwise, we get the "printer not connected" or "printer not reponding" messages.  

 

What's the deal?  Is there a fix for this?

 

Thanks.

Product Expert
Posts: 3,255
Registered: ‎10-16-2012

Re: MX892 Keeps losing connection when needed.

Hello dmcameron.

 

Additional troubleshooting will have to be done to narrow down the cause of your issue. The next time the communication issue occurs, please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement