Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎06-11-2014

MP520 - windows8.1 installation problems

Hello all!,

 

I'm new to the forum; I was sent here from the microsoft community forum with this installation issue.

 

I'm experiencing printer installation problems with my bluetooth canon MP520 on my new windows 8.1 machine. 

 

printer: Canon MP520 with an external bluetooth "dongle" via the printer USB-port to connect

 

This printer was connected to my previous windows 7 machine, using bluetooth without a problem and is still connected to an iMac machine, also via bluetooth

 

I've found and added the device successfully using the old control panel. Although the driver seemed to be available I downloaded the driver from Canon website and installed following their instructions. In control panel, when selecting the printer, it says "driver is working properly"

 

After completing the above, I've tried to print the test-page but doesn't work. The printer doesn't seem to respond; printer status stalls in "sent to printer". The printer itself is working properly as I can print from other devices without trouble...

 

I've done the common troubleshooting, but all solution proposed on the Microsoft website I have tried (download driver...) and didn't work. I've started checking out the community but seems like many similar questions and no answers beyond what I've tried already...

 

I do remember the printer was easy to install on my previous windows 7 machine, though I had to download a new driver AND for the setup, the machine and printer needed to be connected by wire, not bluetooth. After completing installation over wire on windows 7, it worked properly over bluetooth. Do I need to do the same for windows 8?...

 

I'm stuck, any help appreciated! 

 

 

 

The above is copy-paste from my opening post on the microsoft community; I've tried a few things suggested already, all posted here:

 

http://answers.microsoft.com/en-us/windows/forum/windows8_1-hardware/cannot-install-canon-mp520-blue...

 

tbh, I'm pretty sure it's a windows issue, but maybe someone here knows a solution?...

 

 

any help appreciated! Smiley Happy

 

Kris

Highlighted
New Contributor
Posts: 1
Registered: ‎08-17-2015

Re: MP520 - windows8.1 installation problems

I have exactly the same issue on a newly bought Toshiba satellite running Windows 8.1 64bit. Any problem resolution available?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement