Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎12-24-2018

MG5750 not found on wireless network

Hello guys,


I'm having some troubles finding my new printer on the network. The printer is turned on, the router is on and working.

I connected the printer to my SSID network using my password. I checked my router's admin page and i can see the printer is connected and still the printer can not be found.


Printer: Canon MG5750

Connection is active

IPv4 active with the assigne IP address

Signal Strength 100%


Can't seem to find a solution to make it work, the only way I can print is using Direct Connection but is not my prefered way. 


Can you please help me? Thank you


Merry Christmas

Posts: 552
Registered: ‎06-05-2013

Re: MG5750 not found on wireless network

Hi Afusaru,

Welcome to The Canon Forum! 
We really appreciate your participation, however this appears to be a printer model not suported within the US. The Canon Community is hosted and moderated within the United States by Canon USA. We are only able to provide support for Canon products manufactured for and used within the US market.

If you live outside the United States, please CLICK HERE and select your country or region for your support needs.

You're welcome to discuss Canon products sold outside of the United States, but please be aware that you will not receive support directly from Canon USA.

Occasional Contributor
Posts: 6
Registered: ‎03-16-2019

Re: MG5750 not found on wireless network

Hi there. I'm having exactly the same problem trying to get my printer working.


Did you get any answer anywhere




Occasional Contributor
Posts: 6
Registered: ‎03-16-2019

Re: MG5750 not found on wireless network

Not sure anyone still listening, but I solved this in my case at least. Related to a problem with the router using dual bandwidths. I'll give details if anyone needs.

New Contributor
Posts: 3
Registered: ‎03-25-2019

Re: MG5750 not found on wireless network

Yes I could use some details.  I have a MG5420.  It worked just fine with my old router but got a new dual band router and windows 10 can't find the printer.  AirPrint can't find it either.  Please advise.  Customer support wound not help me.

Occasional Contributor
Posts: 6
Registered: ‎03-16-2019

Re: MG5750 not found on wireless network

Just to expand upon my own solution, I found that when I linked my printer and my laptop to my mobile phone's personal WiFi hotspot, on mobile internet, the printer worked fine. From that, figured there must be a problem with the router, not the laptop or the printer. Backed this up by printing succesfully via USB - again no router involved. Worth a check.


If that does happen, what I found was that my router runs at 2 different bandwidths - either 2.4G or 5G. I think the 2 devices were both linked to the router but on different bandwidths. I went into the router settings via the hub homepage and changed the bandwidth settings to manual. I then manually set both devices to the 2.4G bandwidth and the printer immediately started working over the WiFi.


I am absolutely no expert so it's possible something I did sparked something else to make things happy again, but as I said it's worth a try. Good luck.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement