Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎12-27-2017

I have an older Canon printer .....a MP620B

My Canon MP620 B printer has has lost its WiFi connection with our laptop.  We've recently had a Windows upgrade & believe this to be the issue.  We've tried all the reboots Etc and getting no where, does anyone have a suggestion ?  Our printing message is that it is in error state as well.  Thanks.   PJ

Respected Contributor
Posts: 1,461
Registered: ‎11-19-2017

Re: I have an older Canon printer .....a MP620B


On the PC:

If there are any orphned print jobs stuck in the print queue, please remove or delete them.

Stopping/Restarting the Print Spooler Service will accomplish the same thing.


On the printer:

Now power cycle the printer and reconnect it to your wireless router. 



Return to the computer and open Device and Printers.  Does the printer now show "Ready"?

Bay Area - CA
~6D2 ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~Pixima Pro-100
New Contributor
Posts: 2
Registered: ‎12-27-2017

Re: I have an older Canon printer .....a MP620B

Hi Rick & sorry for the delay getting back.


    I tried all your good suggestions, yet came up short.  I ended up calling Canon Support & they sent a link.  I believe my issue was that I just upgraded a new version of Word & that became troublesome with my printer.  All is a go now, the support staff was nice & patient with me as they walked me through the process.   Again thank you for taking the time to give a hand on this Rick ........very good advice !!!!!    

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement