Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎10-09-2018

Canon TS 9520 will not connect wirelessly to my TP-Link Archer C5400.

[ Edited ]

I just purchased a TS 9520 and for the life of me cannot get it to connect to wirelessly. I've tried all methods.

 

Easy Connect

Manual Connect, where you specify the SSID bradcast name of the router.

WPS Push connect

WPS PIN connect

 

I called Canon support to which they said I need to call my router manufacturer. I'm running a TP-Link Archer C5400. It has a 2.4 ghz band, and two 5 ghz bands.

 

I understand the printer doesn't like WEP, which is fince since I have the router set to WPA. The printer also doesn't like the 5ghz bands from reading the documentation. Which is also fine since I have no problems with the 2.4 ghz band on my router.

 

I have two amazon echos which also connect via the 2.4 band. All devices in my house can see the 2.4 band just fine. Alas, the printer is the only device not recognizing it.

 

When I run the connection it doesn't see the SSID. The printer picks up my neighbors wifi but not mine. I've tried the WPS Push button, and WPS PIN connect methods as well. The manual method where you specify the SSID name and none of the methods work.

 

I had to complete set up over ethernet. It's not ideal, now the printer is in a location I don't want it.

 

I've tried resetting the router, modem and printer x5. Updated the firmare on the printer via ethernet. Then reset router and printer several more times.

 

I was curious if anyone else has run into this issue. I can provide any setting in the router if anyone is interested.

 

Canon Pixma TS 9520

Windows 10 on all machines in the house

Router: TP-Link Archer C5400

Internet: Gigabit

 

Thanks in advance.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement