Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎01-03-2021

Canon MX479 Disconnects from Network

[ Edited ]

Hi everyone! I made an account just to make this thread to see if anyone has any potential solutions for this issue.  My Canon MX479 printer disconnects from the network after a few days of being idle and not in use.  It's a bit of a pain because I will have to go to the printer, reconnect it to the network, go back to the computer to setup up the printer (if it does not auto reconnect), and then finally reprint whtaever document I need.  Kinda defeats the purpose of a wireless printer, no?

 

My computer is a MacBook Air running macOS High Sierra (10.13.6).  The printer is a MX479 and it has the latest firmware installed (version 3.100).  I have the latest printer drivers installed from the Canon website.  My router is a D-Link DIR-1960. The setup on the Network Configuration Page details for the printer are as follows:

 

Connection: Active

Communication Mode: Infrastructure

TCP/IP Version: IPv4

Authentication: WPA2-PSK

Encryption: AES

WEP Key Length: Inactive

Signal Strength: 100%

IPv4 IP Address: Valid IP Address for my Network (192.168.X.X)

Wireless LAN DRX: Enable

WSD: Enable

WSD Timeout: 20mins

LPR Protocol: Enable

DNS Server: Auto

Primary Server: My router's IP Address (192.168.X.X)

 

I tried a few tips I found on the forums, but the issue persists.  After a few days of the printer being idle it disconnects from the network.  The tips I tried already are:

 

  • Turning off IPv6 on the printer
  • Making the WSD Timeout 20mins
  • Setting a static IP Address via the printer's Remote UI
  • Reserving the assigned static IP Address on the router's DHCP configuration page

 

A few things to mention are:

  • When the printer is working, I can access it via the printer's Remote UI using the IP Address.
  • When the printer goes idle and does not want to print wirelessly, I cannot access the printer's Remote UI.
  • When the printer goes idle, I still see it under the DHCP client's list of my router (even before I assigned the static IP Address to it)

 

Anybody else have any other suggestions to try out or maybe previously had this issue and figured out a way to resolve it permanently?  Would appreciate any insight.

 

Thanks,

Danny

New Contributor
Posts: 2
Registered: ‎01-03-2021

Re: Canon MX479 Disconnects from Network

Nobody has additional advice or tips?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement