Canon Community Canon Community
 


Reply
New Contributor
Posts: 4
Registered: ‎07-21-2020

Two 600EX-RT's Not Syncing??

[ Edited ]

Wondering if anyone could help me figure this out. I have two 600EX-RT's that I haven't used in about two years. I tested them for a shoot recently and neither of them are syncing in ETTL or Manual with my 5DIV and my 5DSR. All I see is ambient light with zero flash. My 580EXII and my 480EXII both work normally on both camera bodies. I know it's not exposure compensation. I've checked all the settings on both the flashes and the camera bodies. I've changed the batteries and cleaned the contacts. At this point I would guess the flash is broken but it makes no sense that both flashes are doing the exact same thing? It's driving me nuts. Thanks

VIP
Posts: 11,987
Registered: ‎08-13-2015

Re: Two 600EX-RT's Not Syncing??

I have that happen sometimes on the more recent bodies.  I have found that I need turn on the flash while it is sitting in the shoe BEFORE I turn on the camera.  Mounting the flash, and turning it on usually results in no communication.  

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
New Contributor
Posts: 4
Registered: ‎07-21-2020

Re: Two 600EX-RT's Not Syncing??

Thanks for the suggestion but it didn't help. 

VIP
Posts: 11,987
Registered: ‎08-13-2015

Re: Two 600EX-RT's Not Syncing??


@BobM222 wrote:

Thanks for the suggestion but it didn't help. 


There must be something set that is out of wack somewhere.  I would save the current settings to a custom shooting mode, and then reset the camera back to factory defaults.  

 

A factory reset should not affect custom shooting modes, any AFMA adjustements, and pretty much any menu item that has its's own sub-menu like Custom Controls.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
New Contributor
Posts: 4
Registered: ‎07-21-2020

Re: Two 600EX-RT's Not Syncing??

I'll try but I've been doing a lot of reading and I believe that this has been a recurring problem with some of the first generation advanced Canon speedlights. From what I've found there appear to be issues with the hot shoe pins and the circuit boards. It's just weird that both flashes are doing the exact same thing.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement