Canon Community Canon Community
 


Reply
Highlighted
Frequent Contributor
Posts: 29
Registered: ‎07-04-2018

Speedlite 600EX-RT Intermittent Power On Problem...

Has anyone experienced the problem where you turn on the 600EX-RT and nothing happens? A few nudges and bumps of the flash in my hand and the power comes on?

 

Put in fresh batteries and made sure all the contacts were clean... but it seems to be happening more and more often. 

 

Anybody else experience this with the flash? I have 2 of them now that are doing this.

Highlighted
Reputable Contributor
Posts: 977
Registered: ‎11-14-2012

Re: Speedlite 600EX-RT Intermittent Power On Problem...

There is a known problem with 600EX and the filter holder SCH-E1. Do you have SCH-E1 mounted?
DCS 3c, DCS 520, D30, D60, 1Ds, 300D, 30D, 1000D IR, 7D, 6D, 6D, M5
15-45/3.5-6.3 IS, 16-35/4 IS, 22/2, 24/1.4 II, 24-105/4 IS, 50/1.4, 85/1.8, 100/2.8, 70-200/2.8 IS II, 300/2.8 IS
Highlighted
Frequent Contributor
Posts: 29
Registered: ‎07-04-2018

Re: Speedlite 600EX-RT Intermittent Power On Problem...

Yes... I read about the problem with the SCH-E1 Color Filter Holder. I only have a MagMod attached. I havn't heard anything about the magnets in the MagMod affecting anything?

 

Magmod

Highlighted
Esteemed Contributor
Posts: 4,186
Registered: ‎02-17-2016

Re: Speedlite 600EX-RT Intermittent Power On Problem...

I could easily believe that the SCH-E1 uses a magnetic sensor. I would remove the filter holder and try the unit for a while.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement