Canon Community Canon Community
 


Reply
New Contributor
Posts: 4
Registered: ‎05-13-2018

Speedlight not working

I have a canon 7d mark ii and I connected a canon 600 ex-rt speedlight to the top, hooked it in, but the flash will not work. The red light on the front flickers when I take a shot, but the main flash does not go off.
I've tried everything, please help me!
Esteemed Contributor
Posts: 3,614
Registered: ‎06-11-2013

Re: Speedlight not working

I do not have a 7D II (but I do have the 600EX-RT).  Check your menus to make sure you didn't set the flash to 'disabled'.  It is possible to use the flash as a remote commander (master) for slave flashes.  Under the 'flash control' menu, you should see settings for the external flash.  Make sure it isn't disabled.

 

It is ALSO possible to use the menu buttons on the flash itself to disable the flash (and that overrides the camera settings).  I'd check that as well.  

 

 

 

Tim Campbell
5D III, 5D IV, 60Da
Highlighted
New Contributor
Posts: 4
Registered: ‎05-13-2018

Re: Speedlight not working

Thank you so much!
Respected Contributor
Posts: 1,032
Registered: ‎02-06-2013

Re: Speedlight not working

So did you figure out what happened?

================================================
Diverhank's photos on Flickr
New Contributor
Posts: 4
Registered: ‎05-13-2018

Re: Speedlight not working

No I didn't ):
Respected Contributor
Posts: 1,032
Registered: ‎02-06-2013

Re: Speedlight not working


@hollins3022 wrote:
No I didn't ):

Bummer...to rule out the bulb being burnt out, you should try to press the test button without the camera.  The flash should fire when you press it.

================================================
Diverhank's photos on Flickr
New Contributor
Posts: 4
Registered: ‎05-13-2018

Re: Speedlight not working

Is that the red light with the lightning bolt?
If so, I pressed it and nothing happened.
Product Expert
Posts: 28
Registered: ‎05-22-2018

Re: Speedlight not working

Hi hollins3022,

 

Yes, the button that lights up red and has the lightning bold symbol above it is the Test flash button. When it is red, pressing the button should fire a test flash. If the flash is not mounted to the camera does pressing the test button fire the flash head?

 

If the test flash button does not fire the flash head I recommend contacting our Technical Support team for assistance. They can be reached HERE or at the link below.

 

https://www.usa.canon.com/internet/portal/us/home/support/contact-support/

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement