Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎04-15-2021

Canon EXO II Issue

So I was on a shoot yesterday, everything was working fine, until suddenly the recycle time on my flash increased. Like I could normally shoot in burst and not have an issue, but now its like 1-2 seconds between charges. I also can't change the power of the flash. The number changes but the flash itself fires the same, and its as if its firing on 1/1, even its its set to 1/128. I've tried everything I can think of to fix it but I'm not having any luck. Can anyone help?
VIP
Posts: 11,490
Registered: ‎08-13-2015

Re: Canon EXO II Issue

Sounds like a battery that is not at full charge.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
New Contributor
Posts: 3
Registered: ‎04-15-2021

Re: Canon EXO II Issue

Can't be, all the batteries are fully charged. That was my first suscpicion but its not.

Esteemed Contributor
Posts: 4,674
Registered: ‎02-17-2016

Re: Canon EXO II Issue

Could be a failing battery.

New Contributor
Posts: 3
Registered: ‎04-15-2021

Re: Canon EXO II Issue

Issue only started when I tried turning the flash into HSS, but could be. I'll try brand new batteries see what happens. But how does failing battery mean the flash power won't change?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement