Canon Community Canon Community

Occasional Contributor
Posts: 8
Registered: ‎01-10-2018
Accepted Solution

Problems with Wifi Connect AP

I have read through all the previous posts about this but its not helping me. I have a Canon Mark IV, I downloaded the AP to my phone, went through all the steps to set up on the camera in communication settings, typed in the encryption each time I tried to connect, etc etc. I watched several YOU Tube videos that all show the same process as well. 


The camera shows on my phone but says "connected, no internet access" or "connected no Wifi".  My wifi is on perfectly fine, all other devices are connected just fine, my internet is fine on my phone.  


I have started from scratch several times but getting the same result.   not sure what I am missing.


Thanks, Debbie

Posts: 1,687
Registered: ‎07-08-2013

Re: Problems with Wifi Connect AP

Hi, Debbie!

So that the Community can help you better, we need to know exactly which Canon camera model you're using as we have more than one camera with the "Mark IV" designation.  Also, please let us know whether your phone is an Android phone or an iPhone. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

Occasional Contributor
Posts: 8
Registered: ‎01-10-2018

Re: Problems with Wifi Connect AP

Thank, I actually called Canon this morning.  SIMPLE FIX!  All the directions specify to use the Canon Connect easy Connect...which is true but once it is connected to your phone, you need to wait about 5 seconds before using Easy Connect to allow time for the camera and phone to connect together.  I was jumping right in to the Easy Connection on my phone, going thru all the prompts each time and still getting the same results. I dont think it specified anywhere to just wait for a few seconds to see if the phone and camera connect to each other. Anyway, its working fine, thank you. The camera is a EOS 5 Mark IV.

Frequent Contributor
Posts: 45
Registered: ‎12-26-2018

Re: Problems with Wifi Connect AP

For EOS 5DIV, I have the connection issue the 5D4 unable to connect to my home Wifi by entering WPS PIN and then the router was reset SSID to factory default, sounds terrible, I have to re setup  my router SSID, I tried the 5DIV to connect by WPS 3 times and same in result it  reset my router SSID to factory default, I give up to connect by WPS PIN method. I end up to connect by entering the wifi passwords. my router is Asus 87U. 

Any one have the same issue ? Cheers.

Occasional Contributor
Posts: 8
Registered: ‎01-10-2018

Re: Problems with Wifi Connect AP

Wow, that sounds brutal. I never even tried to connect via PIN.  Everything I had pointed to the WIFI and Easy Connection. I just wasnt waiting long enough to let it connect.  My whole problem was solved by just calling Canon Tech Support. They answered right away and walked me thru it. Being a new 5D user that had Wifi, I didnt even know what to look for so this was a huge help to me

New Contributor
Posts: 1
Registered: ‎05-09-2019

Re: Problems with Wifi Connect AP

I use Cannon Connect with my 6D for bird photography.  At first I couldn't figure out how to pair it with my iPhone 8.  I called Canon Support and a rep patiently talked my through the process.


I now use it with my 6D with 600 mm SIgna zoom aimed at a bird feeder about 30 feet away. My iPhone works about 40 feet from the camera with one interior wall in between.  I can sit in an easy chair and wait for birds to come and then snap the shutter.


There is some latency in the image on the iPhone -- about 3-4 seconds, which takes some getting used to.  



powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement