Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 11
Registered: ‎01-29-2018

Print studio pro plugin problem

I’ve recently set up photoshop elements 15 on a new computer and can’t get print studio pro plugin to work. 

The download works fine but it doesn’t show up in photoshop elements.

Here is what I got from system info: 

Plug-ins that failed to load:

Canon Layout Plug-In for Print Studio Pro NO VERSION - - from the file “CNPSPPLayout”
Canon Print Studio Pro Export NO VERSION - - from the file “CNPSPP03”
Canon Print Studio Pro NO VERSION - - from the file “CNPSPP01”
PSP NO VERSION - - from the file “CNPSPP02”


Installed TWAIN devices: NON

 

Any help would be greatly appreciated, thank!

Highlighted
VIP
Posts: 13,026
Registered: ‎12-07-2012

Re: Print studio pro plugin problem

I have not tried but PSP may not be compatible with PSE 15, yet.   They will probably have an update soon.

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Occasional Contributor
Posts: 11
Registered: ‎01-29-2018

Re: Print studio pro plugin problem

Thanks for the quick respose.

 

That's what's weird, I had PSP working fine on my old Windows 7 computer, but now that I've switched over to windows 10 I can seem to get it to load on PE15. I noticed that Canon has already updated for PE 2018 so there shouldn't be an issue with PE 15. I saw an Adobe forum that the issue was a Canon printer driver for the Pixma pro 100 was showing as a good driver but really wasn't. Once he downloaded the printer drivers directly from Canon he was able to get PSP integrated into PE 15.

 

That's my next step, I'll let other people know if it works for me.

 

Thanks again!  

Highlighted
VIP
Posts: 13,026
Registered: ‎12-07-2012

Re: Print studio pro plugin problem

That might be the issue.  Don't use the XPS driver.  Use the regular one.

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Occasional Contributor
Posts: 11
Registered: ‎01-29-2018

Re: Print studio pro plugin problem

Cool, thanks for the heads up, I wasn't sure which one to download.

Highlighted
VIP
Posts: 13,026
Registered: ‎12-07-2012

Re: Print studio pro plugin problem

[ Edited ]

The XPS driver gave me lots of problems.  An hour long talk with Canon support did not resolve the issue either.

I am using Photoshop 6 and Lightroom 6 with the Pro-100 printer.  However, when I did manage to get a print from the XPS drive vs the regular drive I could not see any difference so stick with the regular driver.  Less headaches!

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Occasional Contributor
Posts: 11
Registered: ‎01-29-2018

Re: Print studio pro plugin problem

Thanks, I’ll try the regular driver first and see what happens.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement