Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎02-11-2019
Accepted Solution

Help regarding Image Transfer Utility

So, I set up my account, and connect my camera to Canon Image Gateway, I do the process of installing the ITU, but when I right-click it in the taskbar to add a new camera, it asks me to log in right? It asks me for a username when I have none. Capture 234.PNGThis is very frustrating, as going to the website help just tells me "Your profile information is stored at myid.canon. Reset your password at myid.canon." But when I go to the website that it tells me to go to, all it says is my first and last name and my email. There is no option to add a username either. Oh, and clicking "Member registration" on the  ITU just brings me to Canon Image Gateway. Which I have already logged into, AND THAT'S WHERE I FOUND THE HELP PAGE, SO NOTHING HELPS ME.

Sorry, at this point im just very frustrated, if someone could help me that would be very nice. Thank you.

Highlighted
VIP
Posts: 8,041
Registered: ‎08-13-2015

Re: Help regarding Image Transfer Utility

Your initial “username” could your email address.  I have never used it, though.  I do not trust my photos to the cloud.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement