Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎04-26-2018

EOS utility not working

For whatever reason after a few days of not using EOS utility the software will not recognize my camera even if windows 10 does, I have turned off WiFi/NFC and connected it via usb but EOS utility does nothing with it. When I use EOS Utility 3 it just says "Connect an EOS camera." despite it already being connected. When I have used EOS utility 2 the software says "Camera is not recognized" when I launch the software and then connect the camera it immediately closes and gives that message as well.

 

Solutions Tried:

Double checking WiFi/NFC is disabled

Deleting the driver on windows and re-installing it (x10+)

Deleteing and re-installing EOS Utility 2 and 3 (x2)

Contacting support (they didn't seem to read my message and recomended me a solution I had already tried)

Giving up on life

 

Specs:

EOS Rebel T6

Windows 10 Home

 

I just don't know what else to do

Dang_(

Honored Contributor
Posts: 6,538
Registered: ‎08-13-2015

Re: EOS utility not working

Try a different cable.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Valued Contributor
Posts: 450
Registered: ‎11-19-2017

Re: EOS utility not working

[ Edited ]

@Waddizzlewrote:

Try a different cable.


+1 what wadizzle said... 

 

Other possibilities:

-Plug USB directly into port on machine, not into a hub (if you are using one)

-Are you using a 3rd party AV?  If so, try disabling.  

 

If you are using Windows Defender for AV, thats not a problem.  

Rick
Bay Area - CA
~6D2 (f/w 1.0.4) ~16-35mm f2.8L II, 50 f1.8 STM, 85 prime USM, 70-200 f2.8L IS II ~70-300 USM II ~Sigma 24-70 f2.8 Art (f/w 2.01)
~Sigma 150-600 C + TC1401 1.4x (f/w 1.03) ~Speedlite 430 EX II ~DxO PhotoLab Elite ~Windows10 Pro nVidia GPU 1803
Highlighted
New Contributor
Posts: 2
Registered: ‎04-26-2018

Re: EOS utility not working

It did not work

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement