Canon Community Canon Community

Respected Contributor
Posts: 1,565
Registered: ‎11-19-2017

Re: EOS utility does NOTHING

[ Edited ]

Sorry to hear of your issues guys.  I'm running latest non insider build of W10, Fall Creators 1709 (16299.64).  Zero issues here.  In fact I just used the EOS utility to upgrade the FW on my body.  My EOS is latest available 3.7.0, DPP on this box is 4.6.x.  4.7.x everywhere else.


Testing with a different cables as others mentioned is a good first step.


If that fails:


If the EOS utility is running in your System Tray, right-click and quit.


Now open Control Panel > Programs and Features > then select the EOS Utility 3 in your programs list


Press the uninstall/change button at the top of the list.  Perform a repair install


I've not needed to do this myself, and not every sofware includes a repair option..  only Uninstall/Remove


If thats the case, remove the software and restart your PC.


Download a fresh copy of EOS Utility from Canon's website (its easy to find)


Enter your camera Model, press Go.  Then select Drivers and Downloads button on your camera's body page.  EOS 3.7.0 is there.  Install, restart and test again. 


Its possible that a 3rd party AV software might interfere with camera connectivity.  If you are using Windows Defender, that won't cause a problem.


Visit this link for a list of supported models...  Man Happy





Bay Area - CA
~6D2 ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~Pixma Pro-100
New Contributor
Posts: 2
Registered: ‎11-24-2017

Re: EOS utility does NOTHING

Ok finally had some time to figure it out with all the responders and it's working now. I did ll the usual uninstall restart then reinstall a few times, tried disableing then enableing the app in start up. After reading one of the post to go directly to C:\Program Files (x86)\Canon\EOS Utility\EU3\EOS Utility.exe I was getting the the error "EOS Connection app already running" I right clicked and choose "Troubleshoot Compatibility" and followed the prompts, I can now report ALL IS GOOD! Thanks for your help everybody.

New Contributor
Posts: 1
Registered: ‎12-01-2017

Re: EOS utility does NOTHING

I just did the right click and said worked on win 8   When I reconnected and clicked on EOS Utility2 it said that the clock on my pc and clock on camera different and did i want to fix  said yes and all good now   



Thanks for help - just wondering if the clock (daylight savings change) was the issue in the first place?!!  Anywho all good now Smiley Happy

New Contributor
Posts: 3
Registered: ‎01-12-2018

Re: EOS utility does NOTHING

Canon EOS no longer auto dectecting?

It's not your cable or your camera. (I personally shoot a canon t4i)

This frustrated me a ton!!!!




The problem is the version of Windows 10 you have.  If you have version N, everytime Windows updates, you will find your camera (and many other usb devices like smartphones) are no longer detected.


This is a total pain in the arse, but every time Windows 10 does an update you need to download the media feature pack.


Here is the link:


I registered specifically for those who are having the same issue and spent hours sifting through the internet for a solution

New Contributor
Posts: 1
Registered: ‎01-25-2019

Re: EOS utility does NOTHING

Here is something to check. I had used another piece of software that changed drivers. I changed it back as instructed but it loaded the wrong driver back. For Windows 10 the driver is MTP USB Device. So if you go into Device Manager and find the camera listed as a Canon USB Camera, then that is your problem. Right click on it, select update driver, browse for driver, pick from a list, and then select the MTP USB Device. It should now be recognized as a Portable Device and by the name of the camera model. After that, the EOS Utility should load and allow you to use all the options again. 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement