Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎01-14-2018

EOS Utility won't connect with my 80D

Hi everyone,

 

So I purchased a Macbook Pro 2017 to help with some photo/video editing.  I'm running MacOS HIgh Sierra.  I just downloaded the EOS Utility 3.7.0 from the canon site and when I try to connect my canon 80d wirelessly, my computer doesn't see the camera.  I tried connecting the camera directly to the computer via a hdmi cable and still no connection.  I've restarted the computer, deleted the ulitily and reinstalled multiple times and nothing seems to work.  

 

My wife has a Macbook Air running High Sierra and I'm able to connect the camera on her computer.  That's what I was using before I bought the Macbook Pro.  Any advice on something I'm doing wrong?  I just can't figure it out.  Thanks so much!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement