Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 11
Registered: ‎02-27-2021

EOS Utility Problems

I downloaded the lastest EOS Utility and unzipped the file into its own directory. Ran the Setup.exe and all seemed well.

 

However, no Desk shortcut icon was installed nor was there an .exe in the extracted file (other than the setup.exe.) . Therefore, I have no was of starting the EOS Unility.

 

The camera is recognized by the PC....I can get to the DCIM folders.

 

Help!...thanks!

 

Lou

Occasional Contributor
Posts: 11
Registered: ‎02-27-2021

Re: EOS Utility Problems

OK...did some investigating....

 

The installation is a device driver, not a user app so no Icon or .exe. 

 

When I plug in the 60D, the PC recognizes the camera and File Explorer pops-up...but no EOS Utility...

 

Help!

VIP
Posts: 8,136
Registered: ‎11-13-2012

Re: EOS Utility Problems

EOSU2 is the version supported by your camera.

 

Go to the 1D X Mark III support site and download the latest version of EOS Utility; it will support the version of EOSU2 for your camera.

 

Screenshot 2021-04-05 061159.jpg

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic
VIP
Posts: 8,136
Registered: ‎11-13-2012

Re: EOS Utility Problems

What computer operating system?
John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic
Occasional Contributor
Posts: 11
Registered: ‎02-27-2021

Re: EOS Utility Problems

W10 Home....got it to work after a hard, power off reboot.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement