Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎09-08-2017

EOS Utility 3.7.0 / WFT FirewallSetting Crashed

[ Edited ]



I use a Canon 5D Mark IV and recently I download EOS Utility 3.7.0 from Canon and install sucessfully. My window operating system is Win10 64Bit


But I have a problem of "WFT Firewall Setting"


After I run EOS Utility, it alerts for changing WFT Firewall setting and of course I click yes for proceed.

Then it jumps out something like a Command Prompt box and then it pops out "WFT FirewallSettings has stopped Working".


I have tried on a different computer and the result is the same. I have tried to disable my firewall before running the WFT Firewall Settings but still crashed in the end. That doesn't help.


Anyone has any clue for this ??


Thanks a lot


Best regards





PS: These are the information I collected from event log


Fault bucket 129523458530, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: wft firewallsettings.exe
P3: 50986680
P4: mscorlib
P6: 594980a6
P7: e5b
P8: 15a

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_wft firewallsett_735c696fed78275a2ded3a6119ba9d07824b7e5_00000000_183bace3

Analysis symbol:
Rechecking for solution: 0
Report Id: 9e8cf6bf-c7db-4e3a-8fac-935a98228b01
Report Status: 268435456
Hashed bucket: aaab27a9fa3bcc2b62769a801dc5ba72




- <System>
  <Provider Name="Windows Error Reporting" />
  <EventID Qualifiers="0">1001</EventID>
  <TimeCreated SystemTime="2017-09-08T04:32:24.639423100Z" />
  <Security />
- <EventData>
  <Data>Not available</Data>
  <Data>wft firewallsettings.exe</Data>
  <Data />
  <Data>\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8A57.tmp.mdmp \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8AE5.tmp.WERInternalMetadata.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8AF5.tmp.csv \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8B06.tmp.txt</Data>
  <Data>C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_wft firewallsett_735c696fed78275a2ded3a6119ba9d07824b7e5_00000000_183bace3</Data>
  <Data />


Posts: 8,034
Registered: ‎11-13-2012

Re: EOS Utility 3.7.0 / WFT FirewallSetting Crashed

I just tried it and I get to a window like this. W10 (x64).




Do you crash before this appears?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic
New Contributor
Posts: 2
Registered: ‎09-08-2017

Re: EOS Utility 3.7.0 / WFT FirewallSetting Crashed

Crashed before this "EOS Pairing Software" window appears =*(


I wish I saw that window !!


My status is,


1) EOS Utility Launcher is up

2) Press "Pairing over WiFi/LAN"

3) Auto alert for WFT Firewall Setting Changes need to be done

4) Clicked Yes for accepting changes

5) Command Prompt Window pops up.

6) WFT FirewallSetting Crashed Alert Window pops out.


Thx a lot and best regards


Posts: 8,034
Registered: ‎11-13-2012

Re: EOS Utility 3.7.0 / WFT FirewallSetting Crashed

Give Canon a call at 1-800-OK-CANON.
John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic
New Contributor
Posts: 1
Registered: ‎04-28-2018

Re: EOS Utility 3.7.0 / WFT FirewallSetting Crashed

[ Edited ]

I have the same issue - solved with manually allowing UOS utility through firewall.

go to firewall settings and add

Step number 1 



Step number 2


Step number 3




Step number 4




Step number 5


Step number 6



Step number 7


By default should be here - C:\Program Files (x86)\Canon\EOS Utility

I added all the .exe files in cannon EOS utility folder maybe one file is enough I do not know - all of them works fine for me




Step number 8 

then add chosen sotware to firewall exception 


Confirm with firewall then restrat the EOS Utility app - app will not ask you to change firewall settings as this done manually

and you can connect the camera wireless now


powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement