Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎07-13-2018

Re: DPP 4.6.10 Won't Run on OS X (Sierra & El Capitan) - "Graphics processor is not availab


@mox601 wrote:

I have the same problem on a MacBook Pro (13-inch, Mid 2012) with DPP Version 4.7.20.0: is there a way to disable usage of graphics processor before starting up dpp 4?

I don't know if this would solve the problem, since DPP runs fine on a MacBook Pro (Retina, 15-inch, Mid 2015) <snip>


Preamble

It appears that DPP 4.5.20.0 is the latest version that will run on my Late 2013 iMac, which came with OS X 10.9—or maybe 10.8—preinstalled. All later DPP versions AFAIK require
OS X 10.10, 10.11, macOS 10.12, 10.13 PREINSTALLED – UPGRADED MACHINES NOT SUPPORTED
(Quoted from Canon's documentation—emphasis mine—and verified by Canon Support, who were unable to provide a workaround for me.)

Result

Your Mid 2012 MacBook Pro (like my iMac) would have come with an unsupported OS (OS X Lion, in your case) preinstalled—and therefore will not run DPP Version 4.7.20.0. But the Mid 2015 MacBook Pro would have come with an OS (macOS Sierra) that meets the DPP 4.7.20.0 OS requirements—and therefore is able to run DPP 4.7.20.0.

Occasional Contributor
Posts: 13
Registered: ‎03-22-2017

Re: DPP 4.6.10 Won't Run on OS X (Sierra & El Capitan) - "Graphics processor is not availab

Firstly, let me grumble and complain that I received NO help whatsoever from Canon regarding this issue, nor has anyone else who's posted a request for this issue.  It's been nearly 4 years since I first had this issue and requested assistance from Canon.  They were clueless.  This really is unacceptable considering the fact that this is their software.

 

Case senstive formatted APFS is the problem.  I reformatted my Mac tonight and just used APFS (without case sensitivity) and sure enough, DPP now finally runs.  After almost 4 years of f*cking around and dual booting into Windows on my Mac, I have finally solved it, no thanks to Canon.

 

I only recenlty saw a post regarding Photoshop not running on a Mac with a case sensitive file system and it got me thinking that maybe my DPP issue was the same.

 

Sorry to tell everyone that you're going to have to backup everything, run disk utility and reformat without case sensitivity, reinstall Mac OS and then you'll be able to run DPP.  What a pain in the ass...

VIP
Posts: 11,806
Registered: ‎08-13-2015

Re: DPP 4.6.10 Won't Run on OS X (Sierra & El Capitan) - "Graphics processor is not availab


@ObecalpStat wrote:

I tried using the latest DPP (4.6.10) on a brand new/clean/fresh install of Sierra (10.12.3) and I get the error "Graphics processor is not available".

 

I then did a fresh/clean (as in format the hard drive) install of El Capitan, installed the OS updates and then installed DPP 4.6.10 and got the same error.

 

 

 


Did you enable APFS case sensitivity at some point?  It is disabled by default, with lots of WARNINGS about enabling it.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement