Canon Community Canon Community
 


Reply
Honored Contributor
Posts: 5,558
Registered: ‎06-25-2014

Re: Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight


@bytten wrote:

It seems to be a lottery at times, some thought it was windows user profile, some internet explorer, some silverllight (actually many thought this), for me it was none of them, however uninstalling the dropbox client allowed the installation to run to completion and for image browser to work, of course it could stop working again because it's windows (7 x64 for me).  What I can perhaps surmise from these problems, at least in my case is that it was some other program that interrupted comunication with the camera - dropbox rather presumptuously took control of photo uploads without asking (thanks dropbox! - I suggest you drop dropbox ; ) - check autoplay settings and make sure nothing else is in the way, uninstall other image grab programs, make sure silverlight is ok and reinstall 'cleanly' image browser.  good luck and cross your fingers ; )


Dropbox appears to be one of those programs that circumvents the need for administrator privilege by installing itself in the "ProgramData" folder on Windows 7 and 8 machines. Such programs are considered to be particularly vulnerable to viruses that encrypt one's files and then demand ransom in return for the key to decrypt them. I recently purged the Dropbox client from my computers for that reason. Maybe I should try again to install Imagebrowser!  Smiley Wink

Bob
Philadelphia, Pennsylvania USA
New Contributor
Posts: 3
Registered: ‎05-11-2015

Re: Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight

I wish it was Dropbox but it seems I chickened out of installing that in the past. If only some over paid twerp at Canon could tell me what this means

 

Problem signature: Problem Event Name: APPCRASH Application Name: ImageBrowserEX.exe Application Version: 1.5.2.8 Application Timestamp: 54e42490 Fault Module Name: CanonH264Filter.ax Fault Module Version: 1.13.2.1 Fault Module Timestamp: 5358dfbe Exception Code: c0000005 Exception Offset: 0000b502 OS Version: 6.1.7601.2.1.0.256.1 Locale ID: 3081 Additional Information 1: 0a9e Additional Information 2: 0a9e372d3b4ad19135b953a78882e789 Additional Information 3: 0a9e Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

 

On Windows7 64 bit & no mention of a Silverlight problem just a crash with the above useless info.

New Contributor
Posts: 2
Registered: ‎01-01-2016

Re: Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight

Hi

I seem to have the exact same prolem only on windows 8.1! How did you solve it if you ever did solve it? I would really appreciate the help.

Thanks

New Contributor
Posts: 3
Registered: ‎05-03-2015

Re: Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight

I would start looking at video codecs, the crashmodule is listed as CanonH264Filter.ax, reinstall any canon codecs. check any other H264 or similar codecs, perhaps uninstalling them too, before attempting to install.  I presume that imagebrowser actually was up an running at one time and has crashed after initialising.  Search for help regarding this module/filter/dll or whatever it is. That particular file exists on my machine in C:\Program Files (x86)\Canon\Canon MOV Decoder, so that would implicate quicktime as well (in my mind) since MOV is quicktime video format.  Did it crash while decoding/encoding amov file? I suspect you have a bit of work to isolate and identify the contributing factors to the crash

New Contributor
Posts: 4
Registered: ‎08-25-2013

Re: Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight

I have not solved the problem, just went to Pacasta, works great

Occasional Contributor
Posts: 14
Registered: ‎05-08-2013

Re: Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight

In my case the problem was caused by some setting within Internet Explorer.  Although I had never used it (I prefer Firefox) resetting it to 'factory settings' cleared the problem from then on.  But this forum indicates that there are many other causes, 

 

Sot I have an alternate suggestion. Even though ImageBrowser was working after that I never liked it, mainly because it took much longer to download/display images than my 'old' Canon Zoombrowser that I used prior to Windows8.  But it appeared I had no choice but to move to ImageBrowser so I did - but then  I found a version of  ZoomBrowser that would install and work on Windows8.  I have been happily using it ever since, with Windows8, 8.1 and now 10.  It never mentions Silverlight and it downloads and displayes image much faster than ImageBrowser.

 

Here's the details:  It was called ZoomBrowser EX 6.90a and I downloaded it from Softpedia, which actually installed ZoomBrowser EX 6.6.

 

New Contributor
Posts: 2
Registered: ‎04-29-2016

Re: Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight

I just started a different thread not realizing this one was here. I've been having issues with ImageBrowserEX for months - only loading to 80% before I have to force quit in order to get it off my screen - and am super frustrated. Unlike everyone else (or as it seems anyway) I am not running on Windows, but on Mac OS X El Capitan. There are new downloads for everything except ImageBrowser EX and I'm really frustrated. I've been using iPhoto to edit my pics, but I'd really like to edit video and was hoping to use ImageBrowser EX. If there isn't a solution/new downloads soon I am definitely switching to Nikon and NEVER recommending Canon ever again. I get asked what kind of cameras I use for my photography on my blog and social media quite often. I really wish I'd never recommended Canon in the past. Very disappointed. Smiley Sad

New Contributor
Posts: 3
Registered: ‎05-03-2015

Re: Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight

Don't have any experience with macs and canon products however I'm sure imagebrowser should work given that they've published the software and from my point of view canon products do what they're designed to do, there's nothing wrong with them and lots that's good.  Your problems, and it seems those of many others stem from the mixture of other products installed, examine your system for other picture and movie editing products, remove what aren't really necessary. Dropbox has been a problem for me because it circumvented normal good programming and security practices, and most importantly took control over picture downloads from cameras (without specifically asking for permission todo it). If you've got it or other programs that do similar things, dump it/them, at least until you have imagebrowser working. another possible problem is if you've got quicktime installed. Uninstall possible problem apps, uninstall imagebrowser and then reinstall image browser. See how you get on, good luck. By the way, there's no guarantee that nikon products don't have similar problems either

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement