Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎01-30-2018

Can't update DPP 3.15 on iMac

I've tried repeated times to download the latest DPP 4.7.21 on my Late 2012 27" 3.4GHz i7 iMac, running High Sierra OSX 10.13 and it simply refuses to open in the dock.

I've tried both the latest version direct and using the updater from DPP 3.15 that I'm currently using. Neither will open.

I've been on Apple help site for days, and they can't find anything wrong. 

 

Anyone else experienced this and found a way to get it to load?

Highlighted
Moderator
Posts: 640
Registered: ‎06-05-2013

Re: Can't update DPP 3.15 on iMac

Hi TimBall,

Welcome to the Canon forum! So that the Community can help you better, we will need to know what model equipment you are using.  
Any other details you'd like to give will only help the Community better understand your issue.

If this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team by phone or email.

Highlighted
Occasional Contributor
Posts: 5
Registered: ‎01-30-2018

Re: Can't update DPP 3.15 on iMac

Hi, I think I've supplied all the information in my question?

 

 Late 2012, 27" 3.4GHz i7 iMac, running High Sierra OSX 10.13 with 32Gb memory.

 

Trying to download and open DPP 4.7.21. The installer downloads, but then refuses to open in the dock.

 

Let me know if more info needed?

Highlighted
Reputable Contributor
Posts: 861
Registered: ‎10-12-2012

Re: Can't update DPP 3.15 on iMac

Hi TimBall,

 

Which camera model are you using the software with? We may have updated software on our website, but we'll need to know the camera model to point you in the right direction.

 

Thanks!

Highlighted
Occasional Contributor
Posts: 5
Registered: ‎01-30-2018

Re: Can't update DPP 3.15 on iMac

Hi,

 

I'm using Canon G1X, with older files from S90, 5DII, 5D, and 30D. (All shot RAW)

 

Currently I'm using DPP 3.15, but as that is 32 bit based, I need to update to the latest 64 bit DPP 4, to be able to keep opening the files when Mac bring out the next OSX which will only run 64bit apps.

 

Hopefully the older RAW files will still open in DP4?

Highlighted
Honored Contributor
Posts: 5,552
Registered: ‎06-25-2014

Re: Can't update DPP 3.15 on iMac


@TimBall wrote:

Hi,

 

I'm using Canon G1X, with older files from S90, 5DII, 5D, and 30D. (All shot RAW)

 

Currently I'm using DPP 3.15, but as that is 32 bit based, I need to update to the latest 64 bit DPP 4, to be able to keep opening the files when Mac bring out the next OSX which will only run 64bit apps.

 

Hopefully the older RAW files will still open in DP4?


They will, but you won't see any of the changes you made in DPP 3. DPP 3 and DPP 4 maintain entirely separate change areas in the RAW file. And Canon provides no way to convert a RAW file's DPP 3 changes into DPP 4 changes. I know that sounds crazy, but that's how it is. 

Bob
Philadelphia, Pennsylvania USA
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎01-30-2018

Re: Can't update DPP 3.15 on iMac

[ Edited ]

Thanks for that Bob. So there's no way of viewing 32bit DPP 3 processed RAW's, after Apple updates OSX 10.13 to 10.14. That a REAL disappointment.Smiley Sad

 

In that case it takes the steam out of trying to get DPP4.7.21 loaded, as it won't do what I'd wanted in any case, as now I use Lightroom or Capture Onefor most processing. (Although I always found DPP's look, preferable to either)

Highlighted
Honored Contributor
Posts: 5,552
Registered: ‎06-25-2014

Re: Can't update DPP 3.15 on iMac


@TimBall wrote:

Thanks for that Bob. So there's no way of viewing 32bit DPP 3 processed RAW's, after Apple updates OSX 10.13 to 10.14. That a REAL disappointment.Smiley Sad

 

In that case it takes the steam out of trying to get DPP4.7.21 loaded, as it won't do what I'd wanted in any case, as now I use Lightroom or Capture Onefor most processing. (Although I always found DPP's look, preferable to either)


Switching to Lightroom doesn't solve the problem, because Lightroom won't be able to read DPP 3's RAW file edits any more than DPP 4 is.

 

On a Windows computer, DPP 3 runs perfectly well under a 64-bit version of the OS. Are you sure that won't still be true under the new Mac OS?

Bob
Philadelphia, Pennsylvania USA
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎01-30-2018

Re: Can't update DPP 3.15 on iMac

Fairly certain it's curtains for DPP 3 with the next version of OSX, from all I read it won't even try to open/run ANY 32 bit application. Grrr!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement