Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎11-21-2019

Camera connect app connection failed

Hopefully someone can help me fix this problem. I am traveling for 6 months and have a lot of pictures that needs to be transfered to my phone/ipad.

Problem: Suddenly my camera g7x Mark II is failing to connect to every device i have with me. It is failing to connect a Motorola smartphone, an iPhone and ipad.
For 2 months i didnt have any issues to connect with them!

What i tried to do until now:
- uninstall the camera connect app and rebooth the phone and reinstall the app.
- reset the wifi and general settings in the menu of my camera to default.
- ensure that every other wifi connection is not enabled

The phone can see the wifi and I can connect with the password.
In the app I search the camera g7x powershot. The app recognises and makes connection with the camera so i click on it. Then there is a message on the camera to give access to the memory card. I choose Yes and then it immediately gives "camera connection failed" message in the app.

This is the case with every device i have..
I did read and tried all the tips of previous topics about this but i Cant fix it.

If someone know something else to try please let me know.

Thanks in advance,

Kwinten
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement