Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 8
Registered: ‎12-30-2018
Accepted Solution

Camera Connect App not working

A month ago I got a new Apple 8 with IOS 12 on it.
I got it Connected to my EOS 70D and had it working.
It was not always connecting easily but it would connect.
Today while trying to download pictures on a holiday it won’t connect.
At first it Connected but only showed about 6 pictures.
When I selected a picture to view and download. After waiting a minute or 2. The picture was still blurry and could not download.
I tried reboot on phone and camera. This time it just showed black squares where the picture should be.
I have now deleted and tried everything but cannot get the App to connect to the camera.
When I go through the App setup I can assign the SSID and the camera shows the connection but stays on that page and never completed the configuration with the phone.
There was a recent update on my iPhone and there is a selection which leads me to believe there was an update to the app.
Product Expert
Posts: 74
Registered: ‎05-22-2018

Re: Camera Connect App not working

[ Edited ]

Hello Toodyt, 

 

In this type of situation it sounds like a good idea to establish a fresh connection between the camera and phone. Before starting a new connection I recommend a couple of things. I would first uninstall the Canon Camera Connect App from your smartphone, reboot the phone, and then re-install the App. This will make sure the the App is completely uninstalled and latest version of the App is installed fresh.

 

I would then go to the Wi-Fi option in the 3rd Setup (yellow wrench) section of the camera's menu, and set Wi-Fi to disable. After disabling the Wi-Fi turn the camera OFF then back ON. Now go back to the Wi-Fi option in the menu and enable it.

 

Now select the Wi-Fi function option in the menu and choose the Connect to smartphone icon to begin the connection again. If the Connect to smartphone screen shows "Choose Set." and "Review/Change settings", pick the review change settings option to go through the setup process again. If the Connection method screen appears choose the "Camera access point mode" option and proceed through the setup instructions on the camera. 

 

This information can be referenced in the Wi-Fi function instruction manual for the 70D HERE.

 

If this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team by phone or email.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Occasional Contributor
Posts: 8
Registered: ‎12-30-2018

Re: Camera Connect App not working

Thank William!
I know when I was having a problem I did delete the App and reboot the phone.
I thought I had deleted the WiFi settings on the camera as well.
I did delete the App and reboot the phone.
Then I deleted the WiFi settings on the camera and rebooted it.
Installed the App and setup the WiFi connection on the camera.
It Connected as soon as I started the app and all is good!
Thanks again.
New Contributor
Posts: 1
Registered: ‎03-25-2019

Re: Camera Connect App not working

I have a G7x mark 1 and and iPhone SE running iOS 12.1.4.  Camera Connect has been working fine for at least a year but has now stopped working (possibly with the latest iPhone OS upgrade). Now the iPhone recognises the camera WiFi in settings but the camera will not find the iPhone. I have been through the business of deleting the app, rebooting the phone and reinstalling the app (2.0.0) and also 'resetting' the WiFi on the camera it still will not connect. Help please. This has been a very useful app and I am dismayed that it now does not work.

New Contributor
Posts: 1
Registered: ‎06-30-2019

Re: Camera Connect App not working

I am having a similar problem with my M50. I’m trying to download a video to my device and it keeps showing the error message that I don’t have sufficient space on my ipad when I practically have triple of what the video needs. I’ve done all the steps you suggested to Toodyt but it still isn’t working. 

A month ago it was working fine with my Rebel t6i but now it just doesn’t want to work no matter what I do. 

New Contributor
Posts: 2
Registered: ‎08-14-2019

Re: Camera Connect App not working

Having a similar issue since upgrading to a Glaxy Note 9 from a Note 4 - both Android. Camera connect worked great on the old phone and my EOS 80D. Once the camera and phone were connect via WiFi, a click on "Remote Live View Shooting" in the APP established the EOS 80D connection in the APP and I was in business. With the new camera, WiFi connects just fine. But the click on "Remote Live View Shooting" launches "Easy Connection Guide" which never attaches to the WiFi connection. The screen sequence ends with something like "CLICK TO SEE WIFI CONNECTIONS", which of course shows the SSID of the camera and a status of connected. And that's all she wrote. The APP just sits there as useless as a wart. I have to kill "Easy Connection Guide" as it never terminates and has no DONE button.

 

Is this something broken in Camera Connect 2.5.0.14? Or an incompatability with the latest Android? The Note 4 had not had a system update distributed in three years, so both the APP and OS were back leveled.

New Contributor
Posts: 2
Registered: ‎08-14-2019

Re: Camera Connect App not working

PROBLEM SOLVED. Apparently the latest version of Camera Connect is picky about the camera nickname. We had it set to the name of the camera owner. Once we reset it to the default "EOS80D" the APP connected to the phone immediately upon the WiFi connection being established. Apparently the APP didn't recognize the camera's SSID built from the non-default nickname.

Highlighted
Occasional Contributor
Posts: 6
Registered: ‎09-03-2019

Re: Camera Connect App not working

Ok, I have tried everything that was mentioned above and I still have the issue of blurry images and images that don't want to download.

Worked perfectly before until I updated my Iphone 8 to ios 12.4.1

Canon 80D

 

Any other help would be greatly appreciated.

 

 

New Contributor
Posts: 1
Registered: ‎09-14-2019

Re: Camera Connect App not working

Switched from Android S2 to Android Se5 tablet, camera connect worked fine for a time, now stuck on quick connect loop, needs password (I don't have one). Have deleted and rebooted then reinstalled app, no luck. EOS80D. Help please- on a big vacation and very frustrating. (App does show it is seeing camera on quick connect page, but then says not connected).

New Contributor
Posts: 1
Registered: ‎09-15-2019

Re: Camera Connect App not working

Just started having the same issue on vacation. I have uninstalled the app and reinstalled and when I get to the device can operate the camera, it immediately disconnects. What’s going on?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement