Showing results for 
Show  only  | Search instead for 
Did you mean: 

CanoScan LiDE 220 "Release Lock Switch" Error Message


I get a msg: Release lock switch ... and code 2, 179, 12 // told to uninstall DLL HOW



Welcome Bill66,

We are going to need more than a truncated title in order to try and assist you.

LiDE 220 Scnr. I get a msg: Release lock switch ... and code 2, 179, 12 // told to uninstall DLL HOW

The scanner itself is about 7 yrs old.  Did it work previously?

If so, with what operating system and build?  Since you mention DLL I suspect windows, but cannot be sure.

Release lock switch is a mechanical issue.  This is engaged when the device is shipped from Canon.  It could also be engaged if you planned to transport the scanner.  It has to be unlocked for the scanner to work properly. Its located on the bottom of the device, its clearly marked. 

Canon Knowledge Base - Unlock the Scanning Unit on LiDE 110, LiDE 120, ...

If you want more information about the error, you'll need to provide a screen shot and more information about the device, its history and your operating environment. 





Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It


I have this problem too - ever since Windows 10 update a week ago.  

Scanner worked the week before and IF, on occasions, it agrees that it is not locked, it scans and gives a black page.

Software uninstalled and latest version re-installed from Canon website, still no luck.

I am tired of buying more Canon Lide's whenever Windows updates - this is the second I have purchased in a space of 5 years...

click here to view the press release