cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

XF605 Canon Factory Warranty Service - Shipping and Repair?

JCin
Contributor

I posted on 6-3 "XF605 Blank Screen When Turned On". https://community.usa.canon.com/t5/Professional-Video/XF605-Blank-Screen-When-Turned-On/td-p/480962 Did not receive any replies but had the issue again. So it has happened twice where I turn the camera on and the screen is blank, even the vf. Turn it off and on again and it is fine. I used the camera over 12 hours a few days ago and no issues (I did have a back up camera for this event, just in case).

Anyway called Canon Support about my concern. They sent me a form with info, etc. Found it odd that I was told not to send it in the original box because they probably will not send it back that way. Instead to just bubble wrap it. Paid $4,500 for this camera and it seems kind of crappy that I can't protect the camera in it's original packaging. I'm also wondering if it is worth the trouble of possibly having my camera damaged for them to tell me there is nothing wrong with it. Sorry for venting, I guess I'll brake out the bubble wrap.

 

 

6 REPLIES 6

shadowsports
Legend
Legend

Greetings,

Three things I would do / check.

1. Test with another battery or AC adapter

2. Reset the camera's settings to defaults

3. If you have any accessories connected or installed, remove them and retest.

If none of this helps, break out the bubble wrap and package up your camera for Canon.  If you package it well, you won't have any issues.  You may even want to double box it with plenty of padding.  Ship UPS or FedEx and buy insurance.  Summer is a busy time of year for support/repair, but soon your camera will be back and running normally again.  

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks for reply shadowsports. It is an intermittent issue that has only happened twice. That is why I said wondering if it is worth the trouble, for them to tell me there is nothing wrong. I will take your suggestions into consideration. I also will try and see if I can recreate the issue. One thing I know is I can't have this permanently happening during a shoot. Thanks for heads up on busy season.

Danny
Moderator
Moderator

Thanks for joining the conversation, JCin!  When shipping an item to a Canon Factory Service Center, we always recommend plenty of bubble wrap and a sturdy cardboard box.  We don't recommend using the original purchase box as that box isn't designed to be a shipping package.  It's not that sturdy and it poses a security risk as it tells everyone what's inside.  You want to pack your camera in such a way that it's both well-cushioned and anonymous.

Hope this helps!

Thanks Danny. I wouldn't ship it in just the original box though as advised I would ship it as you described. However, being that is an intermittent issue that has only happened twice, I'm going to hold off on shipping it in and try to figure it out first. Both times the screen was blank, it was with the same Canon BP-60 battery. I know that a poor battery could lead to the screen not coming on.

Is there a way to test this battery to see if it is faulty or has a short?

I'm going to see if I can recreate the issue with this battery and if it happens, start using another battery, etc. The XF605 is my main event camera and I have sometime now before the next event shoot and I also have time on my warranty. I might have to bring a back up camera again if a gig comes up sooner.

 

shadowsports
Legend
Legend

Greetings,

Batteries can always be tested with an ohms meter.  You'll want to measure the voltage at various points of discharge.  100% > 70% > 50% > 30%, etc.   I would start with a full settings reset and another power source.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I will give that a try first. thanks!

Avatar
click here to view the gallery
Announcements