cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't Get My R5 C to Mount on Mac; RAW Video Not Downloaded

Qbert1000
Contributor

I feel like a dummy posting this, but I'm having trouble importing my RAW video footage from my R5 C.  I can import the photos through the Canon Utility, and I can even import some of the proxy files, but I can't get the camera to even mount on my Mac.  Running the latest software on the Mac (Monterey 12.3.1).  Do I have to import through Premiere or Final Cut?  Or is there a simpler way to just drag and drop straight from the camera?  I'm currently connecting using the USB C cable that came with the camera (does it need an HDMI cable for RAW video?).  To be clear, I can access the files via my CF Express card reader, but not when I directly plug the camera into the Mac.  Thanks for any thoughts

9 REPLIES 9

Nick2020
Product Expert
Product Expert

Hi Qbert1000,

Thanks for checking in with us.

I suggest that you try using EOS Utility, one of the programs we provide for the camera. You can download the software from our website. Let's start by going to www.canoneos.com.

On the new page that loads, click on DRIVERS & DOWNLOADS link on the top right. Enter your camera model in the prompt, select it from the options that load under the box, and then press ENTER on your keyboard.

Select the latest version of EOS Utility and then save the file to a convenient location on your computer.

The file you download is actually a zipped file. When it finishes downloading, you'll want to double click the file. This will create another file with a drive icon in the same location. Double click that and you should see the installer screen. Follow the onscreen instructions, and the programs you need should then install.

Once you've installed the software, connect the camera by USB and turn it on. Then, use EOS UTILITY to connect. That's one of the programs in the CANON UTILITIES folder that gets created in your APPLICATIONS folder.

If problems persist, try switching the camera mode to movies before connecting.

The EOS Utility doesn't show the video files, only the photo files. If you read Qbert1000's post you'd see that they already tried EOS Utility "I can import the photos through the Canon Utility." I am also looking for a solution to import the video files when the camera is connected through USB and EOS Utility doesn't work (it previously worked for the R5, but not the R5C, so I'm assuming the video files are accessed differently on this model).

 

I'm having the same issue. It amazes me if canon somehow crippled the ability to copy videofiles from the camera without a card reader? Did you solve the issue?

jrhoffman75
Legend

From the R5 C video manual.

Screenshot 2022-05-05 183102.jpg

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

These are all non-RAW files.  The problem is the RAW files seem to be larger in size, and I can't get those files to download.

Hi Jonn, I did see that page before and had already tried the XF Utility as well, but that one also doesn't seem to recognize the camera regardless of which mode it's turned to. It seems to only work with a card reader or another volume unless I'm missing something. I even tried switching the USB mode in the settings and that didn't make a difference.

Hi Mate! Did you solve this? I have the same issue. It's super annyoing.

No unfortunately. I did finally get my CFexpress card reader in so I'm using that, but no luck getting it to work through USB directly to the camera.

jrhoffman75
Legend

Although it just says SD card, the paragraph in the middle of the page seems to imply that there isn't cable download capability.

Maybe give Canon a call at 1-800-OK-CANON.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic
Announcements
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!