cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pro-10 firmware

camomo
Apprentice

Anyone successful update the firmware 2.031 on Pro-10 by USB-C MacBook Pro?

I'm using 2018 MBP, and had tried many time, the connection drop before the sending the firmware to printer.

Not sure is it the isseus of USB-C? I'm using Apple USB-C adapter.

 

1 ACCEPTED SOLUTION

https://community.usa.canon.com/t5/Professional-Photo-Printers/Canon-pro-100-firmware-upgrade-from-1...

See posting number 39. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

View solution in original post

6 REPLIES 6

shadowsports
Legend
Legend

Greetings,

Its possible the PIN out of the adapter does not match or is correct for the FW update utility.

 

A different cable or computer might be the best way to solve.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

camomo
Apprentice
the PIN out of the USB-C to USB adapter?
I’ve tried 2 adapter, one is USB only, the other is USB and HDMI. Both have same result

jrhoffman75
Legend
Legend

@camomo wrote:

Anyone successful update the firmware 2.031 on Pro-10 by USB-C MacBook Pro?

I'm using 2018 MBP, and had tried many time, the connection drop before the sending the firmware to printer.

Not sure is it the isseus of USB-C? I'm using Apple USB-C adapter.

 


It may be the same problem others have experienced. Is your current FW 1.1?

 

Canon has never officially reported anything on this forum, but on DPReview a poster reported a communication he had with Canon supoort in the EU that stated that FW 1.1 is the latest for printers with a certain PC board and later printers came with a different board at 2.0 series FW came on that printer.

 

Bottom line is many folks with Pro-100 or Pro-10 macOS or Windows get the same error message and failure to install.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

camomo
Apprentice
Thanks John
yes, my FW is 1.1. Let me check it again tonight, however I bought many years ago, so it should be the old type.
Do you have the link of DRPreview?

https://community.usa.canon.com/t5/Professional-Photo-Printers/Canon-pro-100-firmware-upgrade-from-1...

See posting number 39. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

camomo
Apprentice
thank you!
Announcements