Showing results for 
Search instead for 
Did you mean: 

Printer says it is not connected with my mac


My printer is so unpredictable, and it shouldn't be. It says it is offline sometimes and it wont print no matter how many times i turn it off and turn it back on, restart my computer, etc. I print through wifi because i have a cannon MG5495 series and it is so frustrating needing to print something out one day for a class and it not work, but just magically it will start working the next day or day after. Any ideas as to why this might be happening or what I can do to fix this? I did not pay this much money for printer for it to only work sometimes. please please please help me!



Hi cpc5,


So we can better assist you, please reply with the following information:


1.  What version of Mac OS is on your Mac?  You can find this information by going to your APPLE MENU and selecting ABOUT THIS MAC.


2.  How far away is your printer from your wirelessly access point or router?


If this is a time-sensitive matter, additional support options are available at Contact Us.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I have just installed my new Canon TS6050


It was simple. Everything went as planned.


Only now, my Mac is being told the pjrinter is not connected. It shows me the printer, it is set as defauilt, but still won't print.


Mac OS 10.9.5






Try restarting your Mac to see whether or not this will allow the unit to communicate with your computer.


If the issue persists, troubleshooting with our support group will be needed to narrow down the cause of your issue. Please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.


If the asaasdfaasdf

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


How do I correct this problem of my TR7500 printer from not staying connected?



Check to make sure that your Mac is on the same Wi-Fi network as the printer. 


If the communication issues persists, find more help at Contact Us.





Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


I have a iMac with OS X Wl Capitan version 10.11.6. My printer is a Color ImageCLASS 741Cdw. I downloaded the drivers for my device from Canon since the disk that came with my printer was for Windows. The printer and my computer are both connected to my WiFi and are the same distance from the router (they are side by side). I can print from my iPad and my iPhone without any trouble and I can copy, but I cannot print or scan to my computer because it says my printer is not connected. I have been through the manual and tried trouble shooting until I want to pull my hair out. I am just at a loss. Any help is appreciated. Ty

Hi anniesonshine and  LisaLaughon.


Check whether your computer is connected to your network on a 5 GHz wifi connection.  If it is, switch it to the 2.4 GHz connection and try printing again.  If that doesn't correct the issue, or if your network doesn't separate 5 GHz and 2.4 GHz wifi, then try opening the printer's Remote UI from the computer.  If the Remote UI does not open, then your network is not allowing the computer and printer to communicate.  If the Remote UI opens, then something on the computer is preventing them from communicating.


LisaLaughon, you may also wish to check the printer's network connection strength.  Ensure the strength is Good or better.  Depending on how far the printer is from the router, you may need to move it closer.  If the problem seems to occur at certain times of day, or when printing from particular rooms, it's likely a 5 GHz/2.4 GHz wifi issue.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hi -- I have the same problem. My MacBook Pro laptop won't connect with my Canon MF741/743 printer. It worked fine before then suddenly stopped working. When I try to print, it just says "Offline. default."  I have both printer & laptop connected to a non-5G network and there is sufficient Wi-Fi strength on the signal indicator, laptop and printer are both next to the wireless router. I've tried turning off laptop, router and printer, then turning them back on, to no avail.


This is the most expensive printer I ever purchased, so I'm frustrated that it's not working. Would appreciate any assistance you can offer.


Mahalo (thanks),



This is a setup that has been working smoothly for years.


I am on a Mid 2010 MacPro running Sierra 10.12. I am printing via the Canon Export plugin in Photoshop CC to a Canon ipf8300.

I had made the usual troubleshooting movements like:

Updated the drivers.


Replaced the network cable and tested the connection.


Deleted and regenerated the print queue using ImagePROGRAF Printer Setup

 - btw the ImagePROGRAF Printer Setup does not see the printer.


Checked the ipV4 setup of the printer, its on


I am going to try a fresh install on another computer with a different version of macOS next...

Does anyone here have any ideas as to what knocked my setup down?