Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎01-18-2017

mx922 stopped connecting to my computer

I am running windows 10. 


I have downloaded and updated all drivers and utilities for the mx922 all in one.


Few days ago all I had to do was reconnect the printer wifi to my modem then it would print fine.  However now the printer will not connect to my modem and times out.  I have unplugged the printer, I have rebooted the modem I have rebooted my computer. I have pressed the access button on the top of the modem several times to try and reconnect my printer.


I have done all i can think of.  Oh great canon Guru of All in ones... please help this poor soul who needs to print out Girl Scout cookie order forms for her daughter!  Cat Tongue 


But seriously I really would Heart some help here and solve this delimma.




Mynx  ;;;=^..^=,,,

New Contributor
Posts: 1
Registered: ‎03-08-2018

Re: mx922 stopped connecting to my computer

[ Edited ]

From what I've read on the board and using Google, there seems to be a few solutions.


  1. Update your drivers and Windows updates (always the default "solution")
  2. Disable IPv6 on your printer (you can do it through the menu or the web page for your printer - read the docs on how to do this)
  3. Configure a DHCP reservation for your printer on your modem/router


For me, none of the above worked.  I use Windows 10 and Linux.  No operating system was able to detect it.  Connectivity was spotty.  A power off/on of the printer would work for a limited time.  Wired would work for a limited time.  I bout this printer because of the quality of printing, the features, ability to configure the networking without bloated software (which is common with HPs), multiple color cartridges, and cost.  So I NEED wireless.  USB is not an option and ethernet (printer to cable modem) didn't work long term.


Nothing seems to work permanently for me.  I have a DHCP reservation on my cable modem.  That worked briefly (like until the printer went into sleep/standby).  What seems to be working now is I manually configured the printer to a static IP.  I used the same IP that is reserved on my cable modem.  I then put in two public DNS servers (Level 3: and Google:  This is working now on Windows 10 (print and scan).  Been an hour and still works.  Keeping fingers crossed!  Hope it works tomorrow and also on my Linux OS.


If I can't get this to stay connected reliably, I'm off to find another more reliable print and scan solution!  Don't need fax...stopped using that when I stopped using my modem and serial/parallel ports!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement