Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 7
Registered: ‎08-24-2020

Re: canon tr8520- won't scan

Just bumping this to the top, I was hoping for a solution, or a technical person from Canon to chime in with some ideas.  I'm still having the same issue.

New Contributor
Posts: 1
Registered: ‎11-04-2020

Re: canon tr8520- won't scan

[ Edited ]

I am having this same problem and nothing seems to fix it. I can no longer scan from the printer or from the computer. The printer no longer finds my PC and my PC can't find the scanner. I can print just fine, just not scan. I have tried the network utility tool and that does not fix the issue either - it says everything is fine. 

 

I am using windows 10. I am connected via wireless LAN. I tried to connect wireless DIRECT but it will not recognize the password. 

 

Canon - what is the solution here? What happened that this was working fine and suddenly it's not???

New Contributor
Posts: 2
Registered: ‎09-04-2018

Re: canon tr8520- won't scan

I've been using the IJ Scan Utility Lite for years with the same laptop on the same wifi network, and it has worked consistently for scanning. Printing over wifi has worked consistently as well.  Suddenly, a couple of weeks ago, my mac can't find the printer almost every time I try to print something.  I have to turn off and restart the printer, and then it works.  At the same time, the IJ Scan Utility completely stopped being able to connect to the printer, and I can't get that to work at all.  Any idea why this would suddenly change after literally years of consistently being fine?  I didn't change any settings, that I know of.  My Mac is on version Catalina, 10.15.7.

Product Expert
Posts: 3,658
Registered: ‎07-28-2014

Re: canon tr8520- won't scan

Hi hardhat,

 

Please try these steps:

 

 1.  Click on the Apple in the upper left hand corner and then System Preferences.

 

 2.  Click on Printers & Scanners.

 

 3.  Click on the TR8520 on the left side and then [-] at the bottom to remove it.  Repeat until all TR8520's are gone.

 

 4.  On your TR8520, please select the gear icon at the bottom of the display of the printer.

 

 5.  Select Settings.

 

 6.  Select Device settings.

 

 7.  Select LAN settings.

 

 8.  Select Common settings.

 

 9.  Select TCP/IP settings.

 

10.  Select IPv6 and then Yes.

 

11.  Select Enable/disable IPv6 and select Disable.

 

12.  Press the Home icon in the upper left corner.

 

13.  Turn your PIXMA TR8520 off.

 

14.  Disconnect the power cord to your router.  Wait 5 seconds and then reconnect the power cord.

 

15.  When the router is back online, please turn your PIXMA TR8520 on.

 

16.  In the Printer's window on your Mac, click the [+] at the bottom and then click on Add printer or scanner.

 

17.  In the Add window, click 1 time on the TR8500 that appears.

 

18.  At the bottom, next to "Use", select Airprint from the drop down box.

 

19.  Click Add.

 

20.  The printer will set up.  Once it is, please click on it 1 time on the left side.

 

21.  On the right side, click Scan and then Open Scanner.

 

22.  When Image Capture opens, please attempt to scan.

 

If you are able to scan with Image Capture, please open the IJ Scan Utility and attempt to scan with that application.

 

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 2
Registered: ‎09-04-2018

Re: canon tr8520- won't scan

I have resolved the problem with my printer (and some other devices on my home LAN). My Xfinity wifi modem was set to enable its hotspot. When I disabled that, everything on my network came alive, and every device could see the other devices it was supposed to see. My Mac can now print to and scan from my Pixma TR8520. Also, my Chromecast devices, which I could not see on the network for the last month or so, can now be seen and work as they should. So I would suggest that you check your modem settings. Even if you thought you had disabled your wifi hotspot in the past, as I did, check it anyway. I think Comcast pushed an update that re-enabled the hotspot.

Occasional Contributor
Posts: 7
Registered: ‎08-24-2020

Re: canon tr8520- won't scan

This worked!  I had seen something about the ip6 before, but I probably tried to access it in "Wireless LAN settings" rather than "Common Settings".

 

Actually, when I tried IJ Scan Utility I got the error: The operation couldn’t be completed. (jp.co.canon.ij.scanutilitylite.icadriver error 4294967249.)  which was only because I had first started a scan through the System preferences -> printers & scaners -> open scanner, THEN I tried IJ Scan Utility.  Once I closed out the first scan attempt (which also worked), IJ Scan Utility did work (but a better error message would have been nice).

 

Anyway, thank you, I can't believe after months this is finally solved.

New Contributor
Posts: 3
Registered: ‎04-07-2016

Re: canon tr8520- won't scan

What about for Windows users?

Moderator
Posts: 30
Registered: ‎11-12-2019

Re: canon tr8520- won't scan

Hi, jmdinkins! 

If you are using a Windows computer, try installing the latest drivers from our website:

 

PIXMA TR8520 Drivers & Downloads 

 

Select: TR8500 series MP Drivers Ver.1.02 (Windows) listed under Optional Drivers.

 

 

This didn't answer your question or issue? Find more help at Contact Us.

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement