Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎05-25-2019

Printer unable to scan?

Hello! I'm looking for some help with my printer. It's actually my friend's old printer that she gave to me and it's a MG5520. We've tried everything to connect it wirelessly and nothing really worked so I picked up a usb b cable and it still isn't working properly. In my image garden the scan button is greyed out and when I've tried to set up the IJ scan utility it fails to detect the printer wirelessly or through the usb. I'm trying to connect it to my Galaxybook 2 which is running Windows 10. I know that my computer can detect the printer, and I have all the drivers downloaded from the Canon website, I've uninstalled and reinstalled the drivers and other software multiple times, I'm not sure what else I can do.


Thank you in advance for any advice!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement