Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎01-28-2016

Printer is always busy, Please wait a while PIXMA MX492

[ Edited ]

It was working a couple of weeks ago. I have reinstalled my OS, but it should be the same. I installed the drivers from the Canon website. I connected to network over wifi, same as before, and now it won't print. My computer tells me it printed, but nothing comes out of the printer and the printer says "Please wait a while."

 

It just says that forever, even after clearing print jobs. Turning off and back on, it seems like it's fine, but as soon as I try to send a print job it says "Please wait a while" again and nothing ever happens. Computer says it printed.

 

I looked all over the internet and tried some supposed "fixes" for my OS, Debian Linux. I didn't find anything that helped. Not much really out there, mostly bugs from years ago that said they were fixed in the next version. I even tried a support website. They called me, but the guy didn't know how to troubleshoot except with Windows.

 

I'm thinking the printer is trying to print all the jobs, but got stuck and clearing the spool from the computer didn't register with the printer. Anybody know how to clear the printer itself?

Product Expert
Posts: 3,253
Registered: ‎10-16-2012

Re: Printer is always busy, Please wait a while PIXMA MX492

Hello.

 

We cannot guarantee proper functionality with Linux OS's.  Although Linux drivers are available for certain products on our website, we can only support the printer on compatible versions of Windows or Mac OSX.  

 

If you contnue to have difficulties, please install the unit on a compatible Windows or Mac OSX computer for printing.

 

This didn't answer your question or issue? Find more help at Contact Us.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 1
Registered: ‎01-06-2018

Re: Printer is always busy, Please wait a while PIXMA MX492

I was on the phone with a canon rep and he ran me through a few moves because my mx492 isn't printing.  He had me do a "test" and it printed the colored bars and said it was fine.  It wasn't. Just tried to print something and it says please wait a while on the printer.  What is wrong?  I've literally spent 10 hours on this problem.  What is the deal?  I'm on a Mac os X.  I've gone through the whole thing, print, then scan for alignment, etc.  Something with the computer connection to printer is off.  I've got it connected with a usb cause couldn't figure out wireless.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement