Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎10-18-2020

MG7750 double letters for PGBK

Since a couple of weeks my MG7750 prints double characters for text. I did all the cleaning and alignment steps, but nothing helped.

any ideas? 

MG7750_DoubleChar.jpg

Product Expert
Posts: 1,104
Registered: ‎11-19-2018

Re: MG7750 double letters for PGBK

Hi DV_Belgium,

 

I recommend cleaning the encoder strip in your printer. Please click HERE for the steps. If this does not resolve the issue, you printer may require service.

 

The MG7750 is not sold in the United States so if you are contacting us from outside of the US, I recommend contacting the branch of Canon for your region. You may find the correct website using the map on the Canon Global website: http://global.canon/en/support/

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

New Contributor
Posts: 1
Registered: ‎12-23-2020

Re: MG7750 double letters for PGBK

I'm located in N.America. Brought my MG7750 from Germany. It worked great for many years. Suddenly I'm having the same problem, and it's NOT the timing strip. There isn't a speck of grease on it. So what else could it be?

Could it have to do with the in cartridge? Because just before that started I put a new one in. 

New Contributor
Posts: 2
Registered: ‎10-18-2020

Re: MG7750 double letters for PGBK

Hi

I checken cleaned the timing strip. I have the impression there are some markings/scratches/unclarities in this one.On the other hand, only 1 color seems to be affected PGBK. I also tried othe cartridges: same issue

Strange to see only PGBK is affected. is there a way to order a replacement for this strip? I see it's connected with a hook on the right side and a spring on the left side. I could probably do the replacement myself.

Sending it for service will cost more than the printer.

 

New Contributor
Posts: 1
Registered: ‎02-05-2021

Re: MG7750 double letters for PGBK

I have the same alignment problem  with my MG7750 and I did also all the alignment and cleaning, it got a little bit better

but it is not good enough. I wanted to put it in manual mode but the manual mode did not work right. when I check the

box for manual mode it does not work.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement