Canon Community Canon Community

New Contributor
Posts: 3
Registered: ‎05-09-2018
Accepted Solution

MG3022 scan error

I just started to have issues with scanning after having the printer just a couple weeks.  Worked perfectly last week.  I am having no problem communicating with the scanner.  Once the scan is requested, the screen shows the scanner is warming up, then scans normally, then the green bars goes across the screen which is normally associated with transferring the file.  Then this error comes up.  The blank ink cartridge light is on but it doesn't seem like that should affct scanning.  Any suggestions?  I did try holding the stop button for 5-10 seconds to make the ink light go out, but that doesn;t work.  Turned everything off and on several times.  Also does the same for other laptops.





canon 3022 scan error 2.JPG

Product Expert
Posts: 350
Registered: ‎01-20-2016

Re: MG3022 scan error

Hi Rupesy24,


Let's start by re-installing the drivers.


  1. Click HERE.

  2. Scroll down to "Optional Drivers."

  3. Click “Select” next to "MG3000 series MP Drivers."

  4. Press "Download."

  5. Open and run the file.

  6. Follow the onscreen instructions to complete the installation.

This didn't answer your question or issue? Please call or email us at one of the methods on the Contact Us page for further assistance.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

New Contributor
Posts: 3
Registered: ‎05-09-2018

Re: MG3022 scan error

Thanks for the link.  Followed instructions.  Same thing.  Scanner warms up, scans the doc, then green bar for a little while and then this error message:

canon 3022 scan error 3.JPG


Here is a screen shot of wht is installed:


canon 3022 scan error 4.JPG



Problem with the firewall?


New Contributor
Posts: 3
Registered: ‎05-09-2018

Re: MG3022 scan error

I think I figured out the problem.  My office is fairly far away from the wireless router upstairs, however, all my laptops work OK.  I logged into my router and it showed that although everything else in my office had 3 bars for signal, the printer only had 1 bar.  I took the printer somewhere else in the house where it got 3 bars signal and it worked.  I placed it other locations where it got 2 bars and it still didn;t work.  I am just going to buy a signal booster.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement